summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/xc/xc-4.3.2-r1.ebuild')
-rw-r--r--net-dialup/xc/xc-4.3.2-r1.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/net-dialup/xc/xc-4.3.2-r1.ebuild b/net-dialup/xc/xc-4.3.2-r1.ebuild
index 80d46abe0404..8a30fe5dcc95 100644
--- a/net-dialup/xc/xc-4.3.2-r1.ebuild
+++ b/net-dialup/xc/xc-4.3.2-r1.ebuild
@@ -1,16 +1,19 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.1 2004/01/16 10:50:38 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xc/xc-4.3.2-r1.ebuild,v 1.1.1.1 2005/11/30 09:46:08 chriswhite Exp $
+
+inherit eutils
DESCRIPTION="unix dialout program"
HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 ~sparc ~mips"
-DEPEND="sys-libs/libtermcap-compat"
-RDEPEND=""
-S="${WORKDIR}/${P}"
+KEYWORDS="amd64 mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
src_unpack() {
unpack ${A}
@@ -22,9 +25,10 @@ src_unpack() {
epatch ${FILESDIR}/${P}-add-115200.patch
# Fixes the Makefile to use gentoo CFLAGS
- mv ${S}/Makefile ${S}/Makefile.orig
- sed -e "s:GCCOPT\t= -pipe -O2 -fno-strength-reduce -fomit-frame-pointer:GCCOPT\t= ${CFLAGS} -fno-strength-reduce:g" \
- ${S}/Makefile.orig > ${S}/Makefile
+ sed -i \
+ -e "s:GCCOPT\t= -pipe -O2 -fno-strength-reduce -fomit-frame-pointer:GCCOPT\t= ${CFLAGS} -fno-strength-reduce:g" \
+ -e 's:-ltermcap:-lncurses:' \
+ Makefile || die
}
src_compile() {