summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/am-utils/am-utils-6.0.9-r1.ebuild')
-rw-r--r--net-fs/am-utils/am-utils-6.0.9-r1.ebuild55
1 files changed, 27 insertions, 28 deletions
diff --git a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
index 24110ea712d0..14452e88d285 100644
--- a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
+++ b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
@@ -1,46 +1,45 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.1 2003/10/16 15:54:15 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.1.1.1 2005/11/30 09:45:47 chriswhite Exp $
-IUSE="ldap"
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="amd automounter and utilities"
-HOMEPAGE="http://www.am-utils.org"
+HOMEPAGE="http://www.am-utils.org/"
SRC_URI="ftp://ftp.am-utils.org/pub/am-utils/${P}.tar.gz"
-DEPEND="virtual/glibc
- ldap? ( >=net-nds/openldap-1.2 )"
-
-SLOT="0"
LICENSE="BSD"
-KEYWORDS="~x86 amd64"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ldap"
+
+RDEPEND="ldap? ( >=net-nds/openldap-1.2 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
src_unpack() {
unpack ${A}
- cd ${S}
- cat ${FILESDIR}/am-utils-gdbm.patch | patch -p1 || die
+ cd "${S}"
+ epatch "${FILESDIR}"/am-utils-gdbm.patch
+ libtoolize --copy --force && \
+ aclocal && \
+ autoconf && \
+ automake || die "autotools failed"
}
src_compile() {
- local myconf
-
- use ldap \
- && myconf="${myconf} --without-ldap" \
- || myconf="${myconf} --with-ldap"
-
- myconf="${myconf} --sysconfdir=/etc/amd"
-
- cd ${S}
- econf ${myconf} || die "configure failed"
- emake || die "make failed"
+ econf \
+ $(use_with ldap) \
+ --sysconfdir=/etc/amd \
+ || die "configure failed"
+ # does not build in parallel #67136
+ emake -j1 || die "make failed"
}
src_install() {
- make DESTDIR=${D} install || die
-
- cp ${FILESDIR}/amd.conf ${D}/etc/amd
- cp ${FILESDIR}/amd.net ${D}/etc/amd
+ make DESTDIR="${D}" install || die "make install failed"
- exeinto /etc/init.d ; newexe ${FILESDIR}/amd.rc amd
+ insinto /etc/amd
+ doins "${FILESDIR}"/amd.{conf,net}
+ newinitd "${FILESDIR}/amd.rc" amd
}