summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/imcom/files/Makefile-1.30_beta8')
-rw-r--r--net-im/imcom/files/Makefile-1.30_beta838
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/imcom/files/Makefile-1.30_beta8 b/net-im/imcom/files/Makefile-1.30_beta8
new file mode 100644
index 000000000000..587f0a3b2ac7
--- /dev/null
+++ b/net-im/imcom/files/Makefile-1.30_beta8
@@ -0,0 +1,38 @@
+prefix=/usr
+exec_prefix = ${prefix}
+bindir = ${exec_prefix}/bin
+datadir = ${prefix}/share
+mandir = ${prefix}/man
+
+all:
+ chmod +x imcom CLI.py LogHandler.py AccountCreator.py
+
+install: all install-docs
+ mkdir -p ${DESTDIR}/${datadir}/imcom
+ cp *.py ${DESTDIR}/${datadir}/imcom
+ mkdir -p ${DESTDIR}/${bindir}
+ cp imcom ${DESTDIR}/${bindir}
+
+install-docs:
+ mkdir -p ${DESTDIR}/${datadir}/doc/imcom${MYVER}
+ cp docs/*.html ${DESTDIR}/${datadir}/doc/imcom${MYVER}
+ cp CONTRIBUTORS LICENSE README README.autostatus TODO WHATSNEW ${DESTDIR}/${datadir}/doc/imcom${MYVER}
+ mkdir -p ${DESTDIR}/${mandir}/man1/
+ cp docs/imcom.1 ${DESTDIR}/${mandir}/man1/imcom.1
+
+
+
+uninstall:
+ rm -rf ${datadir}/imcom
+ rm -f ${bindir}/imcom
+ rm -f ${mandir}/man1/imcom.1
+
+clean:
+ rm -f config.status config.log config.cache *.pyc
+
+distclean: clean
+ rm -rf CVS docs/CVS
+ rm -f imcom Makefile
+ rm -f docs/imcom.7
+ chmod a-x CLI.py LogHandler.py AccountCreator.py
+ rm -f *~ .#*