summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openvpn/openvpn-1.6.0.ebuild')
-rw-r--r--net-misc/openvpn/openvpn-1.6.0.ebuild45
1 files changed, 23 insertions, 22 deletions
diff --git a/net-misc/openvpn/openvpn-1.6.0.ebuild b/net-misc/openvpn/openvpn-1.6.0.ebuild
index 01190283a43b..257ce196dad0 100644
--- a/net-misc/openvpn/openvpn-1.6.0.ebuild
+++ b/net-misc/openvpn/openvpn-1.6.0.ebuild
@@ -1,48 +1,49 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.6.0.ebuild,v 1.1 2004/10/07 20:32:29 warpzero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.6.0.ebuild,v 1.1.1.1 2005/11/30 09:54:42 chriswhite Exp $
+
+inherit gnuconfig
-IUSE="ssl pthreads"
DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compatible with many OSes."
SRC_URI="mirror://sourceforge/openvpn/${P}.tar.gz"
HOMEPAGE="http://openvpn.sourceforge.net/"
-SLOT="0"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc ~alpha ~ppc-macos amd64"
+IUSE="ssl threads"
-DEPEND=">=dev-libs/lzo-1.07
- virtual/os-headers
+RDEPEND=">=dev-libs/lzo-1.07
ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND="${RDEPEND} virtual/os-headers"
src_unpack() {
- unpack ${A}
-
- # an updated config.sub for the uclibc env
- gnuconfig_update
-}
+ unpack ${A}
+ gnuconfig_update
+}
src_compile() {
econf \
- `use_enable ssl` \
- `use_enable ssl crypto` \
- `use_enable pthreads pthread` \
- || die
- emake || die
+ $(use_enable ssl) \
+ $(use_enable ssl crypto) \
+ $(use_enable threads pthread) \
+ || die "configure failed"
+ emake || die "make failed"
}
src_install() {
+ make DESTDIR=${D} install || die "make install failed"
- make DESTDIR=${D} install || die
-
- dodoc COPYING ChangeLog INSTALL PORTS README
+ dodoc ChangeLog INSTALL PORTS README
exeinto /etc/init.d
doexe ${FILESDIR}/openvpn
}
-
pkg_postinst() {
- einfo "The init.d script that comes with OpenVPN expects directories /etc/openvpn/*/ with a local.conf and any supporting files, such as keys."
+ einfo "The init.d script that comes with OpenVPN expects directories"
+ einfo "/etc/openvpn/*/ with a local.conf and any supporting files,"
+ einfo "such as keys."
ewarn "This version of OpenVPN is NOT COMPATIBLE with 1.4.2!"
ewarn "If you need compatibility with 1.4.2 please emerge that version."
}