summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild')
-rw-r--r--net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild49
1 files changed, 37 insertions, 12 deletions
diff --git a/net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild b/net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild
index 767891427b45..8094d928aee3 100644
--- a/net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild
+++ b/net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild,v 1.1 2005/08/06 14:35:11 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.3_alpha7.ebuild,v 1.1.1.1 2005/11/30 09:55:36 chriswhite Exp $
inherit eutils toolchain-funcs
-IUSE="java tcpd"
+IUSE="java tcpd server"
S="${WORKDIR}/vnc_unixsrc"
DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
SRC_URI="mirror://sourceforge/vnc-tight/${P/_alpha/dev}_unixsrc.tar.bz2"
HOMEPAGE="http://www.tightvnc.com/"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~sparc ~x86"
LICENSE="GPL-2"
SLOT="0"
@@ -26,35 +26,60 @@ RDEPEND="${DEPEND}
java? ( || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 ) )"
src_unpack() {
+
+ if ! use server;
+ then
+ echo
+ einfo "The 'server' USE flag will build tightvnc's server."
+ einfo "If '-server' is chosen only the client is built to save space."
+ einfo "Stop the build now if you need to add 'server' to USE flags.\n"
+ ebeep
+ epause 5
+ fi
+
unpack ${A} && cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
epatch ${FILESDIR}/${P}-gentoo.security.patch
epatch ${FILESDIR}/${P}-imake-tmpdir.patch
epatch ${FILESDIR}/x86.patch
+ epatch "${FILESDIR}/${P}"-darwin.patch
}
src_compile() {
- local CDEBUGFLAGS="${CFLAGS}"
-
xmkmf -a || die "xmkmf failed"
- make CDEBUGFLAGS="${CDEBUGFLAGS}" World || die "make World failed"
- cd Xvnc && ./configure || die "Configure failed."
+ make CDEBUGFLAGS="${CFLAGS}" World || die
- if use tcpd; then
- make EXTRA_LIBRARIES="-lwrap -lnss_nis" CDEBUGFLAGS="${CDEBUGFLAGS}" EXTRA_DEFINES="-DUSE_LIBWRAP=1" CC="$(tc-getCC)" || die
- else
- make CDEBUGFLAGS="${CDEBUGFLAGS}" CC="$(tc-getCC)" || die
+ if use server; then
+ cd Xvnc && ./configure || die "Configure failed."
+ if use tcpd; then
+ local myextra="-lwrap"
+ use userland_Darwin || myextra="${myextra} -lnss_nis"
+ make EXTRA_LIBRARIES="${myextra}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_DEFINES="-DUSE_LIBWRAP=1" || die
+ else
+ make CDEBUGFLAGS="${CFLAGS}" || die
+ fi
fi
+
}
src_install() {
# the web based interface and the java viewer need the java class files
- insinto /usr/share/tightvnc/classes ; doins classes/*
+ if use java; then
+ insinto /usr/share/tightvnc/classes
+ doins classes/*
+ fi
dodir /usr/share/man/man1 /usr/bin
./vncinstall ${D}/usr/bin ${D}/usr/share/man || die "vncinstall failed"
+ if ! use server; then
+ rm -f ${D}/usr/bin/vncserver
+ rm -f ${D}/usr/share/man/man1/{Xvnc,vncserver}*
+ fi
+
dodoc ChangeLog README WhatsNew
use java && dodoc ${FILESDIR}/README.JavaViewer
newdoc vncviewer/README README.vncviewer