summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild')
-rw-r--r--net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild b/net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild
index a1df981a4949..23000a2ceb21 100644
--- a/net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild
+++ b/net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild,v 1.1 2004/10/16 17:40:26 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.4.1-r1.ebuild,v 1.1.1.1 2005/11/30 09:45:38 chriswhite Exp $
-inherit gnome2 mono
+inherit gnome2 mono multilib eutils
DESCRIPTION="A GObject wrapper for Bluetooth functionality"
HOMEPAGE="http://usefulinc.com/software/gnome-bluetooth/"
@@ -10,8 +10,8 @@ SRC_URI="http://downloads.usefulinc.com/libbtctl/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc"
-IUSE="mono"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="mono doc"
RDEPEND=">=dev-libs/glib-2
>=net-wireless/bluez-utils-2.7
@@ -19,7 +19,7 @@ RDEPEND=">=dev-libs/glib-2
>=dev-libs/openobex-1
>=dev-lang/python-2.3
>=dev-python/pygtk-2.0
- !sparc? ( mono? ( >=dev-dotnet/mono-0.96 ) )"
+ !sparc? ( mono? ( >=dev-lang/mono-0.96 ) )"
DEPEND="${RDEPEND}
dev-util/intltool
@@ -30,6 +30,12 @@ MAKEOPTS="${MAKEOPTS} -j1"
DOCS="README NEWS ChangeLog AUTHORS COPYING"
USE_DESTDIR="yes"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-libdir.patch
+}
+
src_compile() {
use sparc || G2CONF="`use_enable mono`"
gnome2_src_configure