summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gsl/gsl-1.14-r1.ebuild')
-rw-r--r--sci-libs/gsl/gsl-1.14-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-libs/gsl/gsl-1.14-r1.ebuild b/sci-libs/gsl/gsl-1.14-r1.ebuild
index 24ee52d9da5b..783bd0a496da 100644
--- a/sci-libs/gsl/gsl-1.14-r1.ebuild
+++ b/sci-libs/gsl/gsl-1.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.14-r1.ebuild,v 1.2 2010/06/25 17:21:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.14-r1.ebuild,v 1.3 2010/08/09 09:32:55 xarthisius Exp $
EAPI="3"
@@ -12,10 +12,10 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="cblas static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cblas-external static-libs"
-RDEPEND="cblas? ( virtual/cblas )"
+RDEPEND="cblas-external? ( virtual/cblas )"
DEPEND="${RDEPEND}
app-admin/eselect-cblas
dev-util/pkgconfig"
@@ -24,8 +24,8 @@ pkg_setup() {
ESELECT_PROF="gsl"
# prevent to use external cblas from a previously installed gsl
local current_lib=$(eselect cblas show | cut -d' ' -f2)
- if use cblas && [[ ${current_lib} == gsl ]]; then
- ewarn "USE flag cblas is set: linking gsl with an external cblas."
+ if use cblas-external && [[ ${current_lib} == gsl ]]; then
+ ewarn "USE flag cblas-external is set: linking gsl with an external cblas."
ewarn "However the current selected external cblas is gsl."
ewarn "Please install and/or eselect another cblas"
die "Circular gsl dependency"
@@ -46,13 +46,13 @@ src_prepare() {
}
src_configure() {
- if use cblas; then
+ if use cblas-external; then
export CBLAS_LIBS="$(pkg-config --libs cblas)"
export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
fi
econf \
--enable-shared \
- $(use_with cblas) \
+ $(use_with cblas-external cblas) \
$(use_enable static-libs static)
}