summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hdparm/hdparm-5.7-r1.ebuild')
-rw-r--r--sys-apps/hdparm/hdparm-5.7-r1.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/sys-apps/hdparm/hdparm-5.7-r1.ebuild b/sys-apps/hdparm/hdparm-5.7-r1.ebuild
index 9a3c85620f24..7fd86487ce87 100644
--- a/sys-apps/hdparm/hdparm-5.7-r1.ebuild
+++ b/sys-apps/hdparm/hdparm-5.7-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/hdparm-5.7-r1.ebuild,v 1.1 2004/09/08 16:22:46 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hdparm/hdparm-5.7-r1.ebuild,v 1.1.1.1 2005/11/30 09:56:41 chriswhite Exp $
-inherit gcc eutils
+inherit toolchain-funcs eutils
DESCRIPTION="Utility to change hard drive performance parameters"
HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/hardware/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.ibiblio.org/pub/Linux/system/hardware/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE=""
DEPEND="virtual/libc"
@@ -19,8 +19,9 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i \
- -e "/^CC/s:gcc:$(gcc-getCC):" \
+ -e "/^CC/s:gcc:$(tc-getCC):" \
-e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LDFLAGS/ s:-s:${LDFLAGS}:" \
Makefile || die
}
@@ -30,20 +31,13 @@ src_compile() {
src_install() {
into /
- dosbin hdparm contrib/idectl || die
+ dosbin hdparm contrib/idectl || die "dosbin"
exeinto /etc/init.d
- newexe ${FILESDIR}/hdparm-init-7 hdparm
-
+ newexe ${FILESDIR}/hdparm-init-7 hdparm || die "init.d"
insinto /etc/conf.d
newins ${FILESDIR}/hdparm-conf.d.3 hdparm
doman hdparm.8
dodoc hdparm.lsm Changelog README.acoustic hdparm-sysconfig
}
-
-pkg_postinst() {
- einfo "The rc-script for hdparm has been updated, so make sure "
- einfo "that you etc-update. The script is much more configurable"
- einfo "for details please see /etc/conf.d/hdparm"
-}