summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rename/rename-1.3.ebuild')
-rw-r--r--sys-apps/rename/rename-1.3.ebuild38
1 files changed, 25 insertions, 13 deletions
diff --git a/sys-apps/rename/rename-1.3.ebuild b/sys-apps/rename/rename-1.3.ebuild
index ac7861348e77..74b2be0930b8 100644
--- a/sys-apps/rename/rename-1.3.ebuild
+++ b/sys-apps/rename/rename-1.3.ebuild
@@ -1,23 +1,35 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rename/rename-1.3.ebuild,v 1.1 2003/09/09 16:17:22 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rename/rename-1.3.ebuild,v 1.1.1.1 2005/11/30 09:56:16 chriswhite Exp $
-DESCRIPTION=" Rename is a command-line rename tool. It can substitute, lowcase, upcase large numbers of file names, or change their ownerships. This is a quick and powerful tool written in C with extended regular expression support for searching and substituting pattern strings in filenames."
-SRC_URI="http://rename.berlios.de/rename-1.3.tar.gz"
+inherit toolchain-funcs
+
+DESCRIPTION="tool for easily renaming files"
HOMEPAGE="http://rename.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
+SLOT="0"
+KEYWORDS="ppc ppc64 ppc-macos x86 amd64"
IUSE=""
-src_compile() {
- econf --prefix=/usr || die "Failed to configure"
- emake || die "Failed to compile"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e '/^CFLAGS/s:-O3:@CFLAGS@:' \
+ -e '/strip /s:.*::' \
+ Makefile.in
+ tc-export CC
}
src_install() {
- dobin rename
- doman rename.1
- dodoc README ChangeLog
-}
+ newbin rename renamexm || die
+ newman rename.1 renamexm.1
+ dodoc README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "This has been renamed to 'renamexm' to avoid"
+ ewarn "a naming conflict with sys-apps/util-linux."
+}