summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/htop/htop-0.5.2.ebuild')
-rw-r--r--sys-process/htop/htop-0.5.2.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/sys-process/htop/htop-0.5.2.ebuild b/sys-process/htop/htop-0.5.2.ebuild
index 787319e08dba..685ef3ce3e18 100644
--- a/sys-process/htop/htop-0.5.2.ebuild
+++ b/sys-process/htop/htop-0.5.2.ebuild
@@ -1,28 +1,19 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.5.2.ebuild,v 1.1 2005/05/17 19:13:38 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.5.2.ebuild,v 1.1.1.1 2005/11/30 09:49:10 chriswhite Exp $
-inherit eutils flag-o-matic
+inherit debug flag-o-matic
DESCRIPTION="interactive process viewer"
HOMEPAGE="http://htop.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE="debug"
+KEYWORDS="amd64 ppc sparc x86"
DEPEND="sys-libs/ncurses"
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
src_compile() {
- use debug && {
- append-flags -O -ggdb -DDEBUG
- RESTRICT="${RESTRICT} nostrip"
- }
+ useq debug && append-flags -O -ggdb -DDEBUG
econf || die "configure failed"
emake || die "make failed"
}