summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild')
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild b/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild
index fa75d67d1ac2..9df9de646470 100644
--- a/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild
+++ b/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild
@@ -1,47 +1,44 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild,v 1.4 2003/09/04 13:46:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild,v 1.5 2003/12/04 23:40:37 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times."
-SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
HOMEPAGE="http://gkrellsun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc alpha"
+KEYWORDS="x86 ppc sparc alpha ~hppa ~mips ~amd64 ~ia64"
DEPEND="app-admin/gkrellm
>=media-libs/imlib-1.9.10-r1"
src_compile() {
-
- if [ -f /usr/bin/gkrellm ]
+ if [ -f ${ROOT}/usr/bin/gkrellm ]
then
cd ${S}/src
emake || die
fi
- if [ -f /usr/bin/gkrellm2 ]
+ if [ -f ${ROOT}/usr/bin/gkrellm2 ]
then
cd ${S}/src20
emake || die
fi
-
}
src_install () {
-
dodoc README AUTHORS COPYING
- if [ -f /usr/bin/gkrellm ]
+ if [ -f ${ROOT}/usr/bin/gkrellm ]
then
cd ${S}/src
insinto /usr/lib/gkrellm/plugins
doins gkrellsun.so
fi
- if [ -f /usr/bin/gkrellm2 ]
+ if [ -f ${ROOT}/usr/bin/gkrellm2 ]
then
cd ${S}/src20
insinto /usr/lib/gkrellm2/plugins