summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/flwm/flwm-1.00-r4.ebuild')
-rw-r--r--x11-wm/flwm/flwm-1.00-r4.ebuild38
1 files changed, 22 insertions, 16 deletions
diff --git a/x11-wm/flwm/flwm-1.00-r4.ebuild b/x11-wm/flwm/flwm-1.00-r4.ebuild
index fff9da605609..c96303eaad3c 100644
--- a/x11-wm/flwm/flwm-1.00-r4.ebuild
+++ b/x11-wm/flwm/flwm-1.00-r4.ebuild
@@ -1,26 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r4.ebuild,v 1.1 2003/07/15 14:50:40 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r4.ebuild,v 1.1.1.1 2005/11/30 09:45:01 chriswhite Exp $
+
+inherit eutils
IUSE="opengl"
-S=${WORKDIR}/${P}
DESCRIPTION="A lightweight window manager based on fltk"
SRC_URI="http://flwm.sourceforge.net/${P}.tgz"
HOMEPAGE="http://flwm.sourceforge.net"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 -ppc"
+KEYWORDS="x86 ~ppc amd64"
-DEPEND=">=x11-base/xfree-4.0.1
- >=x11-libs/fltk-1.1*
+DEPEND="virtual/x11
+ >=x11-libs/fltk-1.0
opengl? ( virtual/opengl )"
#Configuration of the appearance and behavior of flwm
- #must be done at compile time, i.e. there is
- #no .flwmrc file or interactive configuring while
+ #must be done at compile time, i.e. there is
+ #no .flwmrc file or interactive configuring while
#running. To quote the man page, "gcc is your friend,"
#so this type of configuration must be done at compile
#time by editing the config.h file. I can't see any
@@ -29,23 +30,28 @@ DEPEND=">=x11-base/xfree-4.0.1
#and edit the config.h to their liking.
src_compile() {
-
+
use opengl && export X_EXTRA_LIBS=-lGL
-
- export CXXFLAGS="${CXXFLAGS} -I/usr/include/fltk-1.1"
- export LIBS="-L/usr/lib/fltk-1.1"
- epatch ${FILESDIR}/fltk1.1.patch
-
+ if has_version '>=x11-libs/fltk-1.1' ; then
+ export CXXFLAGS="${CXXFLAGS} -I/usr/include/fltk-1.1"
+ export LIBS="-L/usr/lib/fltk-1.1"
+
+ epatch ${FILESDIR}/fltk1.1.patch
+ else # fltk-1.0
+ export CXXFLAGS="${CXXFLAGS} -I/usr/include/fltk-1.0"
+ export LIBS="-L/usr/lib/fltk-1.0"
+ fi
+
econf || die
make || die
}
src_install() {
-
+
doman flwm.1
dodoc README flwm_wmconfig
-
+
into /usr
dobin flwm
}