From d9500e52869589be02c4c73894c876a8a7632b5e Mon Sep 17 00:00:00 2001
From: Julian Ospald <hasufell@gentoo.org>
Date: Thu, 22 May 2014 12:06:23 +0000
Subject: restrict broken tests wrt #511006, add lobby USE flag, rm obsolete
 fam USE flag, install ActorEditor binary for +editor

(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
---
 games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild | 140 ++++++++++++++++++++++++++
 games-strategy/0ad/0ad-0.0.16_alpha.ebuild    | 135 -------------------------
 games-strategy/0ad/ChangeLog                  |   9 +-
 games-strategy/0ad/metadata.xml               |   2 +
 4 files changed, 150 insertions(+), 136 deletions(-)
 create mode 100644 games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild
 delete mode 100644 games-strategy/0ad/0ad-0.0.16_alpha.ebuild

(limited to 'games-strategy')

diff --git a/games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild b/games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild
new file mode 100644
index 000000000000..76043c9de79d
--- /dev/null
+++ b/games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild,v 1.1 2014/05/22 12:06:23 hasufell Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets toolchain-funcs gnome2-utils games
+
+MY_P=0ad-${PV/_/-}
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="http://wildfiregames.com/0ad/"
+SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="editor +lobby pch sound test"
+RESTRICT="test"
+
+RDEPEND="
+	dev-lang/spidermonkey:24
+	dev-libs/boost
+	dev-libs/icu
+	dev-libs/libxml2
+	~games-strategy/0ad-data-${PV}
+	media-gfx/nvidia-texture-tools
+	media-libs/libpng:0
+	media-libs/libsdl[X,opengl,video]
+	net-libs/enet:1.3
+	net-libs/miniupnpc
+	net-misc/curl
+	sys-libs/zlib
+	virtual/jpeg
+	virtual/opengl
+	x11-libs/libX11
+	x11-libs/libXcursor
+	editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
+	lobby? ( net-libs/gloox )
+	sound? ( media-libs/libogg
+		media-libs/libvorbis
+		media-libs/openal )"
+DEPEND="${RDEPEND}
+	virtual/pkgconfig
+	test? ( dev-lang/perl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+	epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+	local myconf=(
+		--with-system-nvtt
+		--with-system-enet
+		--with-system-miniupnpc
+		--with-system-mozjs24
+		--minimal-flags
+		$(usex pch "" "--without-pch")
+		$(usex test "" "--without-tests")
+		$(usex sound "" "--without-audio")
+		$(usex editor "--atlas" "")
+		$(usex lobby "" "--without-lobby")
+		--collada
+		--bindir="${GAMES_BINDIR}"
+		--libdir="$(games_get_libdir)"/${PN}
+		--datadir="${GAMES_DATADIR}"/${PN}
+		)
+
+	# stock premake4 does not work, use the shipped one
+	emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+	# regenerate scripts.c so our patch applies
+	cd "${S}"/build/premake/premake4 || die
+	"${S}"/build/premake/premake4/bin/release/premake4 embed || die
+
+	# rebuild premake again... this is the most stupid build system
+	emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
+	emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+	# run premake to create build scripts
+	cd "${S}"/build/premake || die
+	"${S}"/build/premake/premake4/bin/release/premake4 \
+		--file="premake4.lua" \
+		--outpath="../workspaces/gcc/" \
+		--platform=$(usex amd64 "x64" "x32") \
+		--os=linux \
+		"${myconf[@]}" \
+		gmake || die "Premake failed"
+}
+
+src_compile() {
+	# build 3rd party fcollada
+	emake -C libraries/source/fcollada/src
+
+	# build 0ad
+	emake -C build/workspaces/gcc verbose=1
+}
+
+src_test() {
+	cd binaries/system || die
+	./test -libdir "${S}/binaries/system" || die "test phase failed"
+}
+
+src_install() {
+	dogamesbin binaries/system/pyrogenesis
+	use editor && dogamesbin binaries/system/ActorEditor
+
+	insinto "${GAMES_DATADIR}"/${PN}
+	doins -r binaries/data/l10n
+
+	exeinto "$(games_get_libdir)"/${PN}
+	doexe binaries/system/libCollada.so
+	use editor && doexe binaries/system/libAtlasUI.so
+
+	dodoc binaries/system/readme.txt
+	doicon -s 128 build/resources/${PN}.png
+	games_make_wrapper ${PN} "${GAMES_BINDIR}/pyrogenesis"
+	use editor &&
+		games_make_wrapper ${PN}-ActorEditor "${GAMES_BINDIR}/ActorEditor"
+	make_desktop_entry ${PN}
+
+	prepgamesdirs
+}
+
+pkg_preinst() {
+	games_pkg_preinst
+	gnome2_icon_savelist
+}
+
+pkg_postinst() {
+	games_pkg_postinst
+	gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+	gnome2_icon_cache_update
+}
diff --git a/games-strategy/0ad/0ad-0.0.16_alpha.ebuild b/games-strategy/0ad/0ad-0.0.16_alpha.ebuild
deleted file mode 100644
index 36d2b5c68baf..000000000000
--- a/games-strategy/0ad/0ad-0.0.16_alpha.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha.ebuild,v 1.1 2014/05/21 18:09:13 hasufell Exp $
-
-EAPI=5
-
-WX_GTK_VER="2.8"
-
-inherit eutils wxwidgets toolchain-funcs gnome2-utils games
-
-MY_P=0ad-${PV/_/-}
-DESCRIPTION="A free, real-time strategy game"
-HOMEPAGE="http://wildfiregames.com/0ad/"
-SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
-
-LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="editor fam pch sound test"
-
-RDEPEND="
-	dev-lang/spidermonkey:24
-	dev-libs/boost
-	dev-libs/icu
-	dev-libs/libxml2
-	~games-strategy/0ad-data-${PV}
-	media-gfx/nvidia-texture-tools
-	media-libs/libpng:0
-	media-libs/libsdl[X,opengl,video]
-	net-libs/enet:1.3
-	net-libs/miniupnpc
-	net-libs/gloox
-	net-misc/curl
-	sys-libs/zlib
-	virtual/jpeg
-	virtual/opengl
-	x11-libs/libX11
-	x11-libs/libXcursor
-	editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
-	sound? ( media-libs/libogg
-		media-libs/libvorbis
-		media-libs/openal )"
-DEPEND="${RDEPEND}
-	virtual/pkgconfig
-	test? ( dev-lang/perl )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-	epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_configure() {
-	local myconf=(
-		--with-system-nvtt
-		--with-system-enet
-		--with-system-miniupnpc
-		--with-system-mozjs24
-		--minimal-flags
-		$(usex pch "" "--without-pch")
-		$(usex test "" "--without-tests")
-		$(usex sound "" "--without-audio")
-		$(usex editor "--atlas" "")
-		--collada
-		--bindir="${GAMES_BINDIR}"
-		--libdir="$(games_get_libdir)"/${PN}
-		--datadir="${GAMES_DATADIR}"/${PN}
-		)
-
-	# stock premake4 does not work, use the shipped one
-	emake -C "${S}"/build/premake/premake4/build/gmake.unix
-
-	# regenerate scripts.c so our patch applies
-	cd "${S}"/build/premake/premake4 || die
-	"${S}"/build/premake/premake4/bin/release/premake4 embed || die
-
-	# rebuild premake again... this is the most stupid build system
-	emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
-	emake -C "${S}"/build/premake/premake4/build/gmake.unix
-
-	# run premake to create build scripts
-	cd "${S}"/build/premake || die
-	"${S}"/build/premake/premake4/bin/release/premake4 \
-		--file="premake4.lua" \
-		--outpath="../workspaces/gcc/" \
-		--platform=$(usex amd64 "x64" "x32") \
-		--os=linux \
-		"${myconf[@]}" \
-		gmake || die "Premake failed"
-}
-
-src_compile() {
-	# build 3rd party fcollada
-	emake -C libraries/source/fcollada/src
-
-	# build 0ad
-	emake -C build/workspaces/gcc verbose=1
-}
-
-src_test() {
-	cd binaries/system || die
-	./test -libdir "${S}/binaries/system" || die "test phase failed"
-}
-
-src_install() {
-	dogamesbin binaries/system/pyrogenesis
-
-	insinto "${GAMES_DATADIR}"/${PN}
-	doins -r binaries/data/l10n
-
-	exeinto "$(games_get_libdir)"/${PN}
-	doexe binaries/system/libCollada.so
-	use editor && doexe binaries/system/libAtlasUI.so
-
-	dodoc binaries/system/readme.txt
-	doicon -s 128 build/resources/${PN}.png
-	games_make_wrapper ${PN} "${GAMES_BINDIR}/pyrogenesis"
-	make_desktop_entry ${PN}
-
-	prepgamesdirs
-}
-
-pkg_preinst() {
-	games_pkg_preinst
-	gnome2_icon_savelist
-}
-
-pkg_postinst() {
-	games_pkg_postinst
-	gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-	gnome2_icon_cache_update
-}
diff --git a/games-strategy/0ad/ChangeLog b/games-strategy/0ad/ChangeLog
index a7e9f120e004..cfaa91c56b18 100644
--- a/games-strategy/0ad/ChangeLog
+++ b/games-strategy/0ad/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for games-strategy/0ad
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.1 2014/05/21 18:09:13 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 2014/05/22 12:06:23 hasufell Exp $
+
+*0ad-0.0.16_alpha-r1 (22 May 2014)
+
+  22 May 2014; Julian Ospald <hasufell@gentoo.org> -0ad-0.0.16_alpha.ebuild,
+  +0ad-0.0.16_alpha-r1.ebuild, metadata.xml:
+  restrict broken tests wrt #511006, add lobby USE flag, rm obsolete fam USE
+  flag, install ActorEditor binary for +editor
 
 *0ad-0.0.16_alpha (21 May 2014)
 
diff --git a/games-strategy/0ad/metadata.xml b/games-strategy/0ad/metadata.xml
index 14504b9a6f39..8c007dca14af 100644
--- a/games-strategy/0ad/metadata.xml
+++ b/games-strategy/0ad/metadata.xml
@@ -8,5 +8,7 @@
 	</maintainer>
 	<use>
 		<flag name="editor">Include Atlas scenario editor projects</flag>
+		<flag name="lobby">Enable the use of <pkg>net-libs/gloox</pkg>
+			and the multiplayer lobby</flag>
 	</use>
 </pkgmetadata>
-- 
cgit v1.2.3-65-gdbad