From 48a879f50b69113d20c210c6b3978eff1874f7e5 Mon Sep 17 00:00:00 2001
From: Stefan Knoblich <stkn@gentoo.org>
Date: Tue, 1 Feb 2005 22:47:22 +0000
Subject: fixed gcc34 patch, devfs check, ebuild stops if PPP is missing in
 kernel config, see changelog for more details (Portage version: 2.0.51-r15)

---
 net-misc/zaptel/ChangeLog                      |  9 ++++-
 net-misc/zaptel/files/zaptel-1.0.4-gcc34.patch | 30 ++++++++++++++++
 net-misc/zaptel/zaptel-1.0.3.ebuild            |  4 +--
 net-misc/zaptel/zaptel-1.0.4.ebuild            | 49 +++++++++-----------------
 4 files changed, 57 insertions(+), 35 deletions(-)
 create mode 100644 net-misc/zaptel/files/zaptel-1.0.4-gcc34.patch

(limited to 'net-misc/zaptel')

diff --git a/net-misc/zaptel/ChangeLog b/net-misc/zaptel/ChangeLog
index ea13a9eadab7..40a3b4e9a4d5 100644
--- a/net-misc/zaptel/ChangeLog
+++ b/net-misc/zaptel/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for net-misc/zaptel
 # Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.26 2005/01/28 19:09:12 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.27 2005/02/01 22:47:22 stkn Exp $
+
+  01 Feb 2005; Stefan Knoblich <stkn@gentoo.org>
+  +files/zaptel-1.0.4-gcc34.patch, zaptel-1.0.3.ebuild, zaptel-1.0.4.ebuild:
+  New gcc34 patch, provided by Ray Russell Reese III <anti@gentoo.org>,
+  ebuild stops now if required PPP support is missing in kernel config.
+  Fixed check for DEVFS_FS and moved the UDEV message to pkg_postinst.
+  Fixed SRC_URI for 1.0.3.
 
 *zaptel-1.0.4 (28 Jan 2005)
 
diff --git a/net-misc/zaptel/files/zaptel-1.0.4-gcc34.patch b/net-misc/zaptel/files/zaptel-1.0.4-gcc34.patch
new file mode 100644
index 000000000000..ea80c9e0ca06
--- /dev/null
+++ b/net-misc/zaptel/files/zaptel-1.0.4-gcc34.patch
@@ -0,0 +1,30 @@
+diff -ruN zaptel-1.0.4.orig/wcfxs.c zaptel-1.0.4/wcfxs.c
+--- zaptel-1.0.4.orig/wcfxs.c	2005-01-31 14:27:54.828322677 -0500
++++ zaptel-1.0.4/wcfxs.c	2005-01-31 14:32:15.629810758 -0500
+@@ -740,7 +740,7 @@
+     return 0;
+ }
+ 
+-static inline void wcfxs_voicedaa_check_hook(struct wcfxs *wc, int card)
++static void wcfxs_voicedaa_check_hook(struct wcfxs *wc, int card)
+ {
+ #ifndef AUDIO_RINGCHECK
+ 	unsigned char res;
+@@ -884,7 +884,7 @@
+ 	}
+ }
+ 
+-static inline void wcfxs_proslic_check_hook(struct wcfxs *wc, int card)
++static void wcfxs_proslic_check_hook(struct wcfxs *wc, int card)
+ {
+ 	char res;
+ 	int hook;
+@@ -939,7 +939,7 @@
+ 	
+ }
+ 
+-static inline void wcfxs_proslic_recheck_sanity(struct wcfxs *wc, int card)
++static void wcfxs_proslic_recheck_sanity(struct wcfxs *wc, int card)
+ {
+ 	int res;
+ 	/* Check loopback */
diff --git a/net-misc/zaptel/zaptel-1.0.3.ebuild b/net-misc/zaptel/zaptel-1.0.3.ebuild
index a3ecc1a0cfbd..594cec396b11 100644
--- a/net-misc/zaptel/zaptel-1.0.3.ebuild
+++ b/net-misc/zaptel/zaptel-1.0.3.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.0.3.ebuild,v 1.4 2005/01/13 21:19:50 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.0.3.ebuild,v 1.5 2005/02/01 22:47:22 stkn Exp $
 
 IUSE="devfs26"
 
@@ -8,7 +8,7 @@ inherit eutils kernel-mod toolchain-funcs
 
 DESCRIPTION="Pseudo-TDM engine"
 HOMEPAGE="http://www.asterisk.org"
-SRC_URI="ftp://ftp.asterisk.org/pub/telephony/zaptel/zaptel-${PV}.tar.gz"
+SRC_URI="ftp://ftp.asterisk.org/pub/telephony/zaptel/old/zaptel-${PV}.tar.gz"
 
 SLOT="0"
 LICENSE="GPL-2"
diff --git a/net-misc/zaptel/zaptel-1.0.4.ebuild b/net-misc/zaptel/zaptel-1.0.4.ebuild
index 211f51993e75..b808ef4f1a61 100644
--- a/net-misc/zaptel/zaptel-1.0.4.ebuild
+++ b/net-misc/zaptel/zaptel-1.0.4.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.0.4.ebuild,v 1.1 2005/01/28 19:09:12 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/zaptel-1.0.4.ebuild,v 1.2 2005/02/01 22:47:22 stkn Exp $
 
 IUSE="devfs26"
 
@@ -14,30 +14,19 @@ SLOT="0"
 LICENSE="GPL-2"
 KEYWORDS="~x86 ~ppc"
 
+CONFIG_CHECK="PPP"
+ERROR_PPP="PPP support isn't enabled or available as a module! Please reconfigure your kernel to include CONFIG_PPP,
+	CONFIG_PPP_ASYNC CONFIG_PPP_DEFLATE and CONFIG_PPPOE."
+
 DEPEND="virtual/libc
 	virtual/linux-sources
 	>=dev-libs/newt-0.50.0"
 
 pkg_setup() {
-	get_version || die "Unable to calculate Linux Kernel version"
-
-	if ! linux_chkconfig_present CONFIG_PPP
-	then
-		einfo "If you want to use PPP over your hardware:"
-		einfo ""
-		einfo "   Please make sure that your kernel has the appropriate"
-		einfo "   PPP support enabled or present as modules before merging:"
-		einfo ""
-		einfo "   CONFIG_PPP=m"
-		einfo "   CONFIG_PPP_ASYNC=m"
-		einfo "   CONFIG_PPP_DEFLATE=m"
-		einfo "   CONFIG_PPPOE=m"
-		einfo ""
-		einfo "   Quit now, recompile your kernel, and reboot."
-	fi
+	linux-info_pkg_setup
 
 	# show an nice warning message about zaptel not supporting devfs on 2.6
-	if [ "${KV_MAJOR}.${KV_MINOR}" == "2.6" ] && linux_chkconfig_present CONFIG_DEVFS_FS ; then
+	if kernel_is 2 6 && linux_chkconfig_present DEVFS_FS ; then
 		echo
 		einfo "You're using a 2.6 kernel with DEVFS."
 		einfo "The Zaptel drivers won't work unless you either:"
@@ -57,10 +46,6 @@ pkg_setup() {
 		echo
 		einfo "Sleeping 20 Seconds..."
 		epause 20
-	else
-		echo
-		einfo "Sleeping 10 Seconds..."
-		epause 10
 	fi
 }
 
@@ -110,16 +95,6 @@ src_install() {
 	newexe ${FILESDIR}/zaptel.rc6 zaptel
 	insinto /etc/conf.d
 	newins ${FILESDIR}/zaptel.confd zaptel
-
-# FIXME!! Can we (we should) do this automatically
-	einfo "If you're using udev add the following to"
-	einfo "/etc/udev/rules.d/50-udev.rules (as in README.udev):"
-	einfo "# Section for zaptel device"
-	einfo "KERNEL=\"zapctl\",     NAME=\"zap/ctl\""
-	einfo "KERNEL=\"zaptimer\",   NAME=\"zap/timer\""
-	einfo "KERNEL=\"zapchannel\", NAME=\"zap/channel\""
-	einfo "KERNEL=\"zappseudo\",  NAME=\"zap/pseudo\""
-	einfo "KERNEL=\"zap[0-9]*\",  NAME=\"zap/%n\""
 }
 
 pkg_postinst() {
@@ -133,4 +108,14 @@ pkg_postinst() {
 
 	echo
 	einfo "Use the /etc/init.d/zaptel script to load zaptel.conf settings on startup!"
+	echo
+# FIXME!! Can we (we should) do this automatically
+	einfo "If you're using udev add the following to"
+	einfo "/etc/udev/rules.d/50-udev.rules (as in README.udev):"
+	einfo "# Section for zaptel device"
+	einfo "KERNEL=\"zapctl\",     NAME=\"zap/ctl\""
+	einfo "KERNEL=\"zaptimer\",   NAME=\"zap/timer\""
+	einfo "KERNEL=\"zapchannel\", NAME=\"zap/channel\""
+	einfo "KERNEL=\"zappseudo\",  NAME=\"zap/pseudo\""
+	einfo "KERNEL=\"zap[0-9]*\",  NAME=\"zap/%n\""
 }
-- 
cgit v1.2.3-65-gdbad