From 5b543291a1a38a4c52d8c87d99d7f5a1f74ff2ad Mon Sep 17 00:00:00 2001
From: Diego Elio Pettenò <flameeyes@gentoo.org>
Date: Thu, 12 Oct 2006 16:22:46 +0000
Subject: Use autotools eclass and depend on correct versions of autotools.
 Thanks to Patrick Lauer for reporting in bug #151033. (Portage version:
 2.1.2_pre2-r9)

---
 sys-auth/pam_dotfile/ChangeLog                       |  7 ++++++-
 sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7    |  2 ++
 sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7-r1 |  4 ++++
 sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild       | 13 +++++++------
 4 files changed, 19 insertions(+), 7 deletions(-)

(limited to 'sys-auth')

diff --git a/sys-auth/pam_dotfile/ChangeLog b/sys-auth/pam_dotfile/ChangeLog
index 9b940d4663c1..605a54dc23f0 100644
--- a/sys-auth/pam_dotfile/ChangeLog
+++ b/sys-auth/pam_dotfile/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for sys-auth/pam_dotfile
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_dotfile/ChangeLog,v 1.5 2006/05/24 20:49:27 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_dotfile/ChangeLog,v 1.6 2006/10/12 16:22:46 flameeyes Exp $
+
+  12 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+  pam_dotfile-0.7-r1.ebuild:
+  Use autotools eclass and depend on correct versions of autotools. Thanks to
+  Patrick Lauer for reporting in bug #151033.
 
   24 May 2006; Michael Hanselmann <hansmi@gentoo.org>
   pam_dotfile-0.7-r1.ebuild:
diff --git a/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7 b/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7
index 8dc5e4003b92..e4c6a47b1701 100644
--- a/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7
+++ b/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7
@@ -1 +1,3 @@
 MD5 3c7249f4e6d8a9bd756bb4e09f2ed907 pam_dotfile-0.7.tar.gz 229009
+RMD160 a75bd58304ea4acc66630d8c04def859693c1380 pam_dotfile-0.7.tar.gz 229009
+SHA256 88e99da6aaecec19ea294eb10bcb432f1ce506d1ca53d416ea74bb165a3a4534 pam_dotfile-0.7.tar.gz 229009
diff --git a/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7-r1 b/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7-r1
index 6f4cd9813f69..b5ed82260332 100644
--- a/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7-r1
+++ b/sys-auth/pam_dotfile/files/digest-pam_dotfile-0.7-r1
@@ -1,2 +1,6 @@
 MD5 3c7249f4e6d8a9bd756bb4e09f2ed907 pam_dotfile-0.7.tar.gz 229009
+RMD160 a75bd58304ea4acc66630d8c04def859693c1380 pam_dotfile-0.7.tar.gz 229009
+SHA256 88e99da6aaecec19ea294eb10bcb432f1ce506d1ca53d416ea74bb165a3a4534 pam_dotfile-0.7.tar.gz 229009
 MD5 b2c8631cb8b58f37c282b4bcf16db6ae pam_dotfile-patches-1.tar.bz2 2172
+RMD160 d78f9b9e6ed200483137ddbb0e4ce89d74c805e9 pam_dotfile-patches-1.tar.bz2 2172
+SHA256 fa78ddf1bc2c4938925a8bb71be2705d8a38904c1693b0bbb9f2f3c5f4e8dc5b pam_dotfile-patches-1.tar.bz2 2172
diff --git a/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild b/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
index 134a040b4394..21090cf0509f 100644
--- a/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
+++ b/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
@@ -1,8 +1,11 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild,v 1.3 2006/05/24 20:49:27 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild,v 1.4 2006/10/12 16:22:46 flameeyes Exp $
 
-inherit eutils pam
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils pam autotools
 
 MY_P="${P/_beta/beta}"
 S="${WORKDIR}/${MY_P}"
@@ -22,13 +25,11 @@ DEPEND="doc? ( www-client/lynx )
 
 src_unpack() {
 	unpack ${A}
-	cd ${S}
+	cd "${S}"
 
 	EPATCH_SUFFIX="patch" epatch ${WORKDIR}/${PV}
-	sed -i -e 's:./configure:#./configure:' ${S}/bootstrap.sh
-	sed -i -e "s:aclocal:aclocal -I ${WORKDIR}/${PV}/m4:" ${S}/bootstrap.sh
 
-	sh bootstrap.sh
+	AT_M4DIR="${WORKDIR}/${PV}/m4" eautoreconf
 }
 
 src_compile() {
-- 
cgit v1.2.3-65-gdbad