summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/odafileconverter/odafileconverter-24.2.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/media-gfx/odafileconverter/odafileconverter-24.2.ebuild b/media-gfx/odafileconverter/odafileconverter-24.2.ebuild
index 1dd6a18..57f468d 100644
--- a/media-gfx/odafileconverter/odafileconverter-24.2.ebuild
+++ b/media-gfx/odafileconverter/odafileconverter-24.2.ebuild
@@ -13,17 +13,35 @@ SRC_URI="https://download.opendesign.com/guestfiles/Demo/ODAFileConverter_QT5_ln
KEYWORDS="-* ~amd64"
SLOT="0"
LICENSE="all-rights-reserved"
+IUSE="bundled-libs"
RESTRICT="mirror bindist"
RDEPEND="
- media-libs/tiff-compat:4
+ bundled-libs? ( media-libs/tiff-compat:4 )
"
S=${WORKDIR}
QA_PREBUILT="*"
+src_prepare() {
+ eapply_user
+
+ if ! use bundled-libs ; then
+ MY_REMOVE_LIBS=(
+ libQt5
+ )
+ for name in ${MY_REMOVE_LIBS} ; do
+ find "${S}" -name ${name}'*' -delete
+ done
+
+ # remove qt plugins
+ rm -rfv "${S}"/usr/local/bin/ODAFileConverter_${PV}*/plugins
+ rm -rfv "${S}"/usr/local/bin/ODAFileConverter_${PV}*/qt.conf
+ fi
+}
+
src_install() {
# we dont want automated desktop icons
rm -r "${S}"/etc