aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-12-30 12:30:03 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-12-30 12:30:03 +0000
commit961e17075eb84a92cbf748cab6750153272aff51 (patch)
tree9189a5de8612d6d006e3afdedeed1934a23b9794
parentFix depreciation warnings and taberrors. (diff)
downloadjava-config-961e17075eb84a92cbf748cab6750153272aff51.tar.gz
java-config-961e17075eb84a92cbf748cab6750153272aff51.tar.bz2
java-config-961e17075eb84a92cbf748cab6750153272aff51.zip
Eselect modules are now part of eselect-java.
svn path=/projects/java-config-2/trunk/; revision=9130
-rw-r--r--NEWS2
-rw-r--r--setup.py1
-rw-r--r--src/eselect/README1
-rw-r--r--src/eselect/java-nsplugin.eselect208
-rw-r--r--src/eselect/java-vm.eselect163
5 files changed, 2 insertions, 373 deletions
diff --git a/NEWS b/NEWS
index 4c36c66..7a9a9a0 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,7 @@
For full ChangeLog generated from svn commit logs see ChangeLog.
+ * eselect modules are split-out into separate package eselect-java.
+
Changes in 2.1.6:
* Fixes for virtuals that have vms as providers. Needed for for example jaf.
diff --git a/setup.py b/setup.py
index cf8dd3f..99f4946 100644
--- a/setup.py
+++ b/setup.py
@@ -55,7 +55,6 @@ setup (
('share/icons/hicolor/48x48/mimetypes/', ['data/application-x-java-jnlp-file.png']),
('share/pixmaps/', ['data/java-icon48.png']),
('share/java-config-2/launcher', ['src/launcher.bash']),
- ('share/eselect/modules', glob('src/eselect/*.eselect')),
('/etc/java-config-2/', ['config/virtuals']),
('/etc/java-config-2/build/', ['config/jdk.conf','config/compilers.conf']),
('/etc/env.d/',['config/20java-config']),
diff --git a/src/eselect/README b/src/eselect/README
deleted file mode 100644
index b09e3fb..0000000
--- a/src/eselect/README
+++ /dev/null
@@ -1 +0,0 @@
-This is also in the eselect svn, and should also be update there!
diff --git a/src/eselect/java-nsplugin.eselect b/src/eselect/java-nsplugin.eselect
deleted file mode 100644
index 3d21db0..0000000
--- a/src/eselect/java-nsplugin.eselect
+++ /dev/null
@@ -1,208 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: $
-
-inherit tests multilib
-
-DESCRIPTION="Manage the Java plugin for Netscape-like Browsers"
-MAINTAINER="java@gentoo.org"
-SVN_DATE='$Date: $'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
-
-
-PLUGINS_HOME="${ROOT}/usr/share/java-config-2/nsplugin"
-SYSTEM_PLUGIN_DIR="${ROOT}/usr/lib/nsbrowser/plugins"
-SYSTEM_PLUGIN_DIR_32="${ROOT}/usr/lib32/nsbrowser/plugins"
-SYSTEM_PLUGIN_DIR_64="${ROOT}/usr/lib64/nsbrowser/plugins"
-SYSTEM_PLUGIN="${SYSTEM_PLUGIN_DIR}/javaplugin.so"
-SYSTEM_PLUGIN_32="${SYSTEM_PLUGIN_DIR_32}/javaplugin.so"
-SYSTEM_PLUGIN_64="${SYSTEM_PLUGIN_DIR_64}/javaplugin.so"
-
-libdirs=$(list_libdirs)
-if has lib32 ${libdirs} && has lib64 ${libdirs}; then
- IS_MULTILIB="true"
-else
- IS_MULTILIB="false"
-fi
-### show action
-
-## {{{ show stuff
-
- describe_show() {
- echo "Show the current Java browser plugin"
- }
-
- do_show() {
- local system_name=$(get_system_plugin_vm)
- write_list_start "Current Java browser plugin"
- if [[ -z "${system_name}" ]] ; then
- write_kv_list_entry "(unset)" ""
- else
- write_kv_list_entry "${system_name}" ""
- fi
- }
-
-## }}}
-
-### list action
-
-
-
-## {{{ list stuff
- describe_list() {
- echo "List available Java browser plugins"
- }
-
- tweak_list_item() {
- local vm=${1}
- local system_name=${2}
- local mark=""
- if [[ ${vm} == ${system_name} ]]; then
- mark="${mark} $(highlight 'current')"
- fi
- echo "${vm} ${mark}"
- }
-
- tweak_list() {
- local targets=( ${@} )
- system_name=$(get_system_plugin_vm)
-
- for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
- twaek_list_item ${targets[${i}]} ${system_name}
- done
- }
-
- do_list() {
- if [[ ${IS_MULTILIB} != "true" ]]; then
- MULTILIB_MODE="none"
- local system_name=$(get_system_plugin_vm)
- local targets=( $(get_targets) )
- for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
- targets[${i}]=$(tweak_list_item ${targets[${i}]} ${system_name})
- done
-
- write_list_start "Available Java browser plugins"
- write_numbered_list "${targets[@]}"
- else
- MULTILIB_MODE="32"
- local system_name_32=$(get_system_plugin_vm)
- local targets_32=( $(get_targets) )
- for (( i = 0 ; i < ${#targets_32[@]} ; i = i + 1 )) ; do
- targets_32[${i}]=$(tweak_list_item ${targets_32[${i}]} ${system_name_32})
- done
- write_list_start "Available 32-bit Java browser plugins"
- write_numbered_list "${targets_32[@]}"
-
- MULTILIB_MODE="64"
- local system_name_64=$(get_system_plugin_vm)
- local targets_64=( $(get_targets) )
- for (( i = 0 ; i < ${#targets_64[@]} ; i = i + 1 )) ; do
- targets_64[${i}]=$(tweak_list_item ${targets_64[${i}]} ${system_name_64})
- done
- write_list_start "Available 64-bit Java browser plugins"
- write_numbered_list "${targets_64[@]}"
- fi
- }
-## }}}
-
-### set action
-
-## {{{ set stuff
- describe_set() {
- echo "Set the system Java browser plugin"
- }
-
- do_set() {
- if [[ ${IS_MULTILIB} != "true" ]]; then
- if [[ ${#} != 1 ]] ; then
- die -q "Usage: set [nsplugin-vm]"
- fi
- MULTILIB_MODE="none"
- else
- if [[ ${#} != 2 ]] ; then
- die -q "Usage: set [32bit or 64bit] [nsplugin-vm]"
- fi
- case ${1} in
- 32bit) ;;
- 64bit) ;;
- *)
- die -q "Usage: set [32bit or 64bit] [nsplugin-vm]"
- ;;
- esac
- MULTILIB_MODE=${1%bit}
- shift
- fi
-
- local vm=${1}
-
- if is_number "${vm}" ; then
- local targets=( $(get_targets) )
- vm=${targets[$(( ${vm} - 1 ))]}
- fi
-
- if [[ -z ${vm} ]] ; then
- die -q "You didn't specify valid plugin number to set"
- fi
-
- local plugin="${PLUGINS_HOME}/${vm}-javaplugin.so"
-
- if [[ ! -f ${plugin} ]]; then
- write_error_msg "Expected \"${plugin}\" to exist, but it doesn't."
- write_error_msg "Perhaps \"${vm}\" isn't a valid name of VM built with nsplugin?"
- return
- fi
-
- local system_plugin
- case ${MULTILIB_MODE} in
- 32) system_plugin=${SYSTEM_PLUGIN_32} ;;
- 64) system_plugin=${SYSTEM_PLUGIN_64} ;;
- none) system_plugin=${SYSTEM_PLUGIN} ;;
- esac
- mkdir -p $(dirname ${system_plugin}) || die -q "Error creating \"$(dirname ${SYSTEM_PLUGIN})\""
- if [[ -w $(dirname ${system_plugin}) ]] ; then
- ln -sf ${plugin} ${system_plugin} || die -q "Error creating nsplugin symlink"
- else
- die -q "Sorry, you don't have enough permission to set nsplugin"
- fi
- }
-## }}}
-
-get_targets() {
- for plugin in $(ls ${PLUGINS_HOME}/*-javaplugin.so 2>/dev/null);
- do
- local vm=$(plugin_to_vm ${plugin})
- local matches=""
- case ${MULTILIB_MODE} in
- 32)
- [[ ${vm} = emul-linux-* ]] && matches="true"
- ;;
- 64)
- [[ ${vm} != emul-linux-* ]] && matches="true"
- ;;
- none)
- matches="true"
- ;;
- esac
- [[ ${matches} == "true" ]] && echo ${vm}
- done
-}
-
-plugin_to_vm() {
- local base=$(basename ${1})
- echo ${base%-javaplugin.so}
-}
-
-get_system_plugin_vm() {
- local plugin;
-
- if [[ ${MULTILIB_MODE} == "32" ]]; then
- plugin=$(readlink ${SYSTEM_PLUGIN_32})
- elif [[ ${MULTILIB_MODE} == "64" ]]; then
- plugin=$(readlink ${SYSTEM_PLUGIN_64})
- else
- plugin=$(readlink ${SYSTEM_PLUGIN})
- fi
- plugin_to_vm ${plugin}
-}
-
-# vim: ts=4 sw=4 noet fdm=marker
diff --git a/src/eselect/java-vm.eselect b/src/eselect/java-vm.eselect
deleted file mode 100644
index 063b7c2..0000000
--- a/src/eselect/java-vm.eselect
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: $
-
-# Based on kernel.eselect
-
-DESCRIPTION="Manage the Java system and user VM"
-MAINTAINER="java@gentoo.org"
-SVN_DATE='$Date: $'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
-
-VM_BASE=/usr/lib/jvm
-VM_SYSTEM="/etc/java-config-2/current-system-vm"
-VM_USER="${HOME}/.gentoo/java-config-2/current-user-vm"
-VM_CONFIG="/usr/share/java-config-2/vm"
-
-find_targets() {
- local f
- for f in ${VM_BASE}/* ; do
- [[ -L ${f} ]] && echo $(basename ${f})
- done
-}
-
-sym_to_vm() {
- basename $(readlink "${1}")
-}
-
-### show action ###
-
-describe_show() {
- echo "Show the current vm"
-}
-
-do_show() {
- if [[ ${1} == "system" ]]; then
- my_show ${VM_SYSTEM} 'system-vm'
- elif [[ ${1} == "user" ]]; then
- my_show ${VM_USER} 'user-vm'
- else
- my_show ${VM_SYSTEM} 'system-vm'
- my_show ${VM_USER} 'user-vm'
- fi
-}
-
-my_show() {
- local symlink=${1} vm_type=${2}
- write_list_start "Current ${vm_type}"
- if [[ -L "${symlink}" ]] ; then
- write_kv_list_entry "$(sym_to_vm ${symlink})" ""
- else
- write_kv_list_entry "(unset)" ""
- fi
-}
-
-### list action ###
-
-describe_list() {
- echo "List Available Virtual Machines"
-}
-
-do_list() {
- targets=( $(find_targets) )
- write_list_start "Available Java Virtual Machines:"
- local found_build_only
- if [[ -n ${targets[@]} ]] ; then
- local i system_name user_name
-
- [[ -L ${VM_SYSTEM} ]] && system_name=$(sym_to_vm ${VM_SYSTEM})
- [[ -L ${VM_USER} ]] && user_name=$(sym_to_vm ${VM_USER})
-
- for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
- local build_only=$(grep 'BUILD_ONLY' ${VM_CONFIG}/${targets[${i}]} | cut -c 13-16 )
- local mark=""
-
- if [[ "${build_only}" == "TRUE" || "{build_only}" == "true" ]]; then
- mark="$(highlight_warning 'Build Only')"
- found_build_only="TRUE"
- fi
-
- if [[ ${targets[${i}]} == ${system_name} ]]; then
- mark="${mark} $(highlight 'system-vm')"
- fi
- if [[ ${targets[${i}]} == ${user_name} ]]; then
- mark="${mark} $(highlight 'user-vm' )"
- fi
- targets[${i}]="${targets[${i}]} ${mark}"
- done
- write_numbered_list "${targets[@]}"
- else
- write_kv_list_entry "(none found)" ""
- fi
- echo
- if [[ "${found_build_only}" == "TRUE" ]]; then
- write_warning_msg "VMs marked as Build Only may contain Security Vulnerabilities and/or be EOL."
- write_warning_msg "Gentoo recommends not setting these VMs as either your System or User VM."
- write_warning_msg "Please see http://www.gentoo.org/doc/en/java.xml#build-only for more information."
- fi
-}
-
-### set action ###
-
-describe_set() {
- echo "Set a new system or user vm"
-}
-
-do_set() {
- local usage="Usage [user|system] [vm]"
- if [[ ${#} != 2 ]]; then
- die -q ${usage}
-
- elif [[ ${1} == "system" ]]; then
- if [[ -w $(dirname ${VM_SYSTEM}) ]]; then
- my_set ${VM_SYSTEM} ${2}
- else
- die -q "Sorry, you don't have enough premission to set system"
- fi
- elif [[ ${1} == "user" ]]; then
- if [[ ${UID} != 0 ]]; then
- my_set ${VM_USER} ${2}
- else
- die -q "Sorry, you cannot set a user vm as root. Set the system vm instead"
- fi
- else
- die -q ${usage}
- fi
-}
-
-my_set() {
- local target=${2} symlink=${1}
- if [[ -z ${target} ]] ; then
- die -q "You didn't tell me what to set the symlink to"
-
- elif [[ -L "${symlink}" ]] ; then
- set_symlink "${target}" "${symlink}" || die -q "Couldn't set a new symlink"
-
- elif [[ -e "${symlink}" ]] ; then
- die -q "Target file already exists and is not a symlink: ${symlink}"
-
- else
- set_symlink "${target}" "${symlink}" || die -q "Couldn't set a new symlink"
- fi
-}
-
-set_symlink() {
- local target=${1} symlink=${2}
- if is_number "${target}" ; then
- targets=( $(find_targets) )
- target=${targets[$(( ${target} - 1 ))]}
- fi
- if [[ -z ${target} ]] ; then
- die -q "Target \"${1}\" doesn't appear to be valid!"
- elif [[ -d "${VM_BASE}/${target}" ]] ; then
- local sym_dir=$(dirname ${symlink})
- if [[ ! -d ${sym_dir} ]]; then
- mkdir -p ${sym_dir} || die -q "Could not create ${my_dir}"
- fi
- ln -snf "${VM_BASE}/${target}" "${symlink}"
- else
- die -q "Target \"${1}\" doesn't appear to be valid!"
- fi
-}
-
-# vim: set ft=eselect :