summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@tuffmail.com>2014-08-11 18:47:07 -0400
committerBrian Evans <grknight@tuffmail.com>2014-08-11 18:47:07 -0400
commitfa1d8943e262c1f47feed3b30553e92a4cf82ed5 (patch)
tree3b3d5a9296c1db0c0a509d6edd714c69161901a8
parentRespin minimal patches for new MySQL versions (diff)
downloadmysql-extras-fa1d8943e262c1f47feed3b30553e92a4cf82ed5.tar.gz
mysql-extras-fa1d8943e262c1f47feed3b30553e92a4cf82ed5.tar.bz2
mysql-extras-fa1d8943e262c1f47feed3b30553e92a4cf82ed5.zip
Fix minimal builds on MariaDB 10.0.13mysql-extras-20140811-2248Z
-rw-r--r--00000_index.txt6
-rw-r--r--20001_all_fix-minimal-build-cmake-mariadb-10.0.13.patch16
2 files changed, 22 insertions, 0 deletions
diff --git a/00000_index.txt b/00000_index.txt
index 7051194..c184471 100644
--- a/00000_index.txt
+++ b/00000_index.txt
@@ -1508,6 +1508,12 @@
@pn mariadb
@@ Fix the minimal build by reordering CMakeLists.txt
+@patch 20001_all_fix-minimal-build-cmake-mariadb-10.0.13.patch
+@ver 10.00.13.00 to 10.99.99.99
+@pn mariadb
+@@ Fix the minimal build by reordering CMakeLists.txt
+@@ Fixes MDEV-6562
+
@patch 21000_all_sql-5.1.62.patch
@ver 5.01.62.00 to 5.01.64.99
@pn mariadb
diff --git a/20001_all_fix-minimal-build-cmake-mariadb-10.0.13.patch b/20001_all_fix-minimal-build-cmake-mariadb-10.0.13.patch
new file mode 100644
index 0000000..99a46fd
--- /dev/null
+++ b/20001_all_fix-minimal-build-cmake-mariadb-10.0.13.patch
@@ -0,0 +1,16 @@
+=== modified file 'CMakeLists.txt'
+--- a/CMakeLists.txt 2014-08-07 16:06:56 +0000
++++ b/CMakeLists.txt 2014-08-11 21:43:29 +0000
+@@ -466,7 +466,10 @@
+ ADD_SUBDIRECTORY(packaging/solaris)
+
+ IF(NOT CMAKE_CROSSCOMPILING)
+- SET(EXPORTED comp_err comp_sql factorial gen_lex_hash)
++ SET(EXPORTED comp_err comp_sql factorial)
++ IF(NOT WITHOUT_SERVER)
++ SET(EXPORTED ${EXPORTED} gen_lex_hash)
++ ENDIF()
+ # minimal target to build only binaries for export
+ ADD_CUSTOM_TARGET(import_executables DEPENDS ${EXPORTED})
+ EXPORT(TARGETS ${EXPORTED} FILE ${CMAKE_BINARY_DIR}/import_executables.cmake)
+