summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSascha Lucas <sascha_lucas@web.de>2012-02-13 22:46:14 +0100
committerSascha Lucas <sascha_lucas@web.de>2012-02-13 22:46:14 +0100
commit034e150607593341c11511087e0e63656ea31780 (patch)
tree4bc60a871fbf7af3115dad586e997b8d813a6a1d
parentfixed bugs #374405 and 391387 (diff)
downloadnet-mail-034e150607593341c11511087e0e63656ea31780.tar.gz
net-mail-034e150607593341c11511087e0e63656ea31780.tar.bz2
net-mail-034e150607593341c11511087e0e63656ea31780.zip
bumped topal(74); added files missing in previous commit
-rw-r--r--mail-client/alpine/alpine-2.00-r5.ebuild146
-rw-r--r--mail-client/alpine/files/2.00-lcrypto.patch12
-rw-r--r--net-mail/topal/Manifest12
-rw-r--r--net-mail/topal/topal-74.ebuild41
4 files changed, 201 insertions, 10 deletions
diff --git a/mail-client/alpine/alpine-2.00-r5.ebuild b/mail-client/alpine/alpine-2.00-r5.ebuild
new file mode 100644
index 0000000..383ff8a
--- /dev/null
+++ b/mail-client/alpine/alpine-2.00-r5.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alpine/alpine-2.00-r4.ebuild,v 1.4 2011/09/03 16:44:02 armin76 Exp $
+
+EAPI="2"
+
+inherit eutils autotools flag-o-matic
+
+# http://patches.freeiz.com/alpine/patches/${P}/log.txt
+CHAPPA_PL="115"
+
+DESCRIPTION="alpine is an easy to use text-based based mail and news client"
+HOMEPAGE="http://www.washington.edu/alpine/ http://patches.freeiz.com/alpine/"
+SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
+ chappa? ( http://patches.freeiz.com/alpine/patches/${P}/all.patch.gz -> ${P}-chappa-${CHAPPA_PL}-all.patch.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="+chappa doc ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads topal"
+
+DEPEND="virtual/pam
+ >=sys-libs/ncurses-5.1
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )
+ spell? ( app-text/aspell )
+ topal? ( >=net-mail/topal-72 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ !onlyalpine? ( !app-editors/pico )
+ !onlyalpine? ( !mail-client/pine )
+ !<=net-mail/uw-imap-2004g"
+
+maildir_warn() {
+ elog
+ elog "This build of ${PN} has Maildir support built in as"
+ elog "part of the chappa-all patch."
+ elog
+ elog "If you have a maildir at ~/Maildir it will be your"
+ elog "default INBOX. The path may be changed with the"
+ elog "\"maildir-location\" setting in alpine."
+ elog
+ elog "To use /var/spool/mail INBOX again, set"
+ elog "\"disable-these-drivers=md\" in your .pinerc file."
+ elog
+ elog "Alternately, you might want to read following webpage, which explains how to"
+ elog "use multiple mailboxes simultaneously:"
+ elog
+ elog "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
+ elog
+}
+
+pkg_setup() {
+ if use smime && use topal ; then
+ ewarn "You can not have USE='smime topal'. Assuming topal is more important."
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+}
+
+src_prepare() {
+ use chappa && epatch "${DISTDIR}"/${P}-chappa-${CHAPPA_PL}-all.patch.gz
+ use topal && epatch /usr/share/topal/patches/${P}.patch-{1,2}
+
+ if use ssl; then
+ epatch "${FILESDIR}"/2.00-lcrypto.patch
+ eautoreconf
+ fi
+
+ epatch "${FILESDIR}"/2.00-lpam.patch
+ cd "${S}/imap/src/c-client"
+ epatch "${FILESDIR}"/CVE-2008-5514.patch
+}
+
+src_configure() {
+ local myconf="--without-tcl
+ --with-system-pinerc=/etc/pine.conf
+ --with-system-fixed-pinerc=/etc/pine.conf.fixed
+ --with-ssl-certs-dir=/etc/ssl/certs"
+ # fixme
+ # --with-system-mail-directory=DIR?
+ econf $(use_with ssl) \
+ $(use_with ldap) \
+ $(use_with passfile passfile .pinepwd) \
+ $(use_with kerberos krb5) \
+ $(use_with threads pthread) \
+ $(use_with spell interactive-spellcheck /usr/bin/aspell) \
+ $(use_enable nls) \
+ $(use_with ipv6) \
+ $(use topal || use_with smime) \
+ ${myconf}
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine || die
+ doman doc/alpine.1 || die
+ else
+ emake DESTDIR="${D}" install || die
+ doman doc/rpdump.1 doc/rpload.1 || die
+ fi
+
+ dodoc NOTICE || die
+ if use chappa ; then
+ dodoc README.maildir || die
+ fi
+
+ if use doc ; then
+ dodoc README doc/brochure.txt doc/tech-notes.txt || die
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES || die
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt || die
+
+ docinto html/tech-notes
+ dohtml -r doc/tech-notes/ || die
+ fi
+}
+
+pkg_postinst() {
+ use chappa && maildir_warn
+ if use spell ; then
+ elog
+ elog "In order to use spell checking"
+ elog " emerge app-dicts/aspell-\<your_langs\>"
+ elog "and setup alpine with:"
+ elog " Speller = /usr/bin/aspell -c"
+ elog
+ fi
+ if use topal ; then
+ elog
+ elog "In order to use gpg with topal"
+ elog " read /usr/doc/topal/README.txt"
+ elog
+ fi
+ if use passfile ; then
+ elog
+ elog "${PN} will cache passwords between connections."
+ elog "File ~/.pinepwd will be used for this."
+ elog
+ fi
+}
diff --git a/mail-client/alpine/files/2.00-lcrypto.patch b/mail-client/alpine/files/2.00-lcrypto.patch
new file mode 100644
index 0000000..9cbac3f
--- /dev/null
+++ b/mail-client/alpine/files/2.00-lcrypto.patch
@@ -0,0 +1,12 @@
+diff -urp alpine-2.00.org/configure.ac alpine-2.00/configure.ac
+--- alpine-2.00.org/configure.ac 2008-08-08 19:11:31.000000000 +0200
++++ alpine-2.00/configure.ac 2011-11-24 12:01:47.741607522 +0100
+@@ -954,7 +954,7 @@ dnl provide SSL support?
+ if test "x$alpine_SSLTYPE" != "xnone" ; then
+ AC_SEARCH_LIBS(SSL_library_init,ssl,
+ [
+- LIBS="$LIBS -lssl"
++ LIBS="$LIBS -lcrypto -lssl"
+ ])
+ if test "x$alpine_SSLTYPE" = "xnone" ; then
+ AC_MSG_NOTICE([OpenSSL libraries NOT found])
diff --git a/net-mail/topal/Manifest b/net-mail/topal/Manifest
index ca8b64d..0762f22 100644
--- a/net-mail/topal/Manifest
+++ b/net-mail/topal/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA256
-
AUX 64-Makefile.patch 2267 RMD160 60348219f8849e3719bf2678da4858c8f8d48dea SHA1 5fb4a4a6d7c08c29324436d1711b5d7151168205 SHA256 8623312f3eea1fa5ad3a41cd434dbe30cee9011eb3ccbdf459692a5d74e4f9a8
AUX 72-Makefile.patch 2481 RMD160 83f4c210459a581e6e8f10e99ee2d38ee4511dde SHA1 704cc8c8cd9905bb8602fdef2b5d56e5127cd848 SHA256 c824acdda60194bf885733663a6255e03197597cb411f89eecf63cc37ce7baba
DIST topal-package-64.tgz 170401 RMD160 69e5bdd0b2956fc4ead3815304d7e4def4f99292 SHA1 e2939bcff099e8d32e30dc1eef025f9b29b1053a SHA256 e44b879a8e8d96d5f0cad9e2b68056ba05fe4267a6f4d2d50325164be3f48cd5
DIST topal-package-72.tgz 186728 RMD160 80a5493a91fe19f2b92a3e56810035b890cab1fb SHA1 1c05595d6b00db179539620d997c27ef4cf42fd3 SHA256 ccef20b3add7add640931b6de284e90815dade6ddc171b20d35f8d9b3487db52
+DIST topal-package-74.tgz 345208 RMD160 f2bdb06e255a867647b2b2ba872622dcfceee58d SHA1 5a50300faf10169114bd84a1f868f2a976bc7baf SHA256 28215123a1a7298821a9cf16d298dc1e4bb1daed066161c44465c7bf0ed811d7
EBUILD topal-64.ebuild 1069 RMD160 5f9134dd9152d1b063e6c690788c390ded11c92c SHA1 1a41b0a2d57fd85e0d47b99c779687680982c3fb SHA256 5a83c6fabc3b600b55a0a213f41bcdde45cb85275cf4589c3748c3a4b6bf0983
EBUILD topal-72.ebuild 1117 RMD160 53feb80355e36d9aaf8ad2c07a1563adba145414 SHA1 2c2717deb70402b1f672dee3272d89e1b1aeb4eb SHA256 74ef8dffb57d629ea404b1f6d01bb8c2075dca25f943b035e0907a4efad1b4ed
+EBUILD topal-74.ebuild 1119 RMD160 5c2173bb7a29ed5648eca4bc2c1b3a4356dd7b5b SHA1 cc6b0e9d29abd43ab07105f0484429c4a4e3f781 SHA256 e17697bfe77fa51c9bd66be025fd3917abe56e4abfd4adb1c64c4798b086edaf
MISC ChangeLog 1367 RMD160 e0e8927aa0b027267d8e40d07b87e5f484c74b1c SHA1 b29c0d80e36acec04512d48030d655a2816dfcfd SHA256 3646e43cf1491c5d632fceb2e4493810057bbe0ba06694199391b8efd5db6db3
MISC metadata.xml 433 RMD160 91fef629634574556108d901437922eb33de1054 SHA1 b9b7d25e163f9d7324691053f059427aeabfc63d SHA256 20be76d34b7465137697e575336303c4ad625646dec31a1031562c69654aabaf
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.18 (GNU/Linux)
-
-iEYEAREIAAYFAk6RUoIACgkQV3J2n04EauwvygCcC0mxp2tsICcNgfw/R+KjJ5Ob
-AB4An1JFjiOWneM2En2xyN0KQ7rMcnxE
-=FN7f
------END PGP SIGNATURE-----
diff --git a/net-mail/topal/topal-74.ebuild b/net-mail/topal/topal-74.ebuild
new file mode 100644
index 0000000..4f7a3f0
--- /dev/null
+++ b/net-mail/topal/topal-74.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/topal/topal-72.ebuild,v 1.3 2011/08/26 15:40:27 hwoarang Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Topal is a 'glue' program that links GnuPG and Pine/Alpine."
+HOMEPAGE="http://homepage.ntlworld.com/phil.brooke/topal/"
+SRC_URI="http://homepage.ntlworld.com/phil.brooke/topal/rel-${PV}/topal-package-${PV}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-crypt/gnupg-2.0.7-r1
+ || ( net-mail/metamail app-misc/run-mailcap )
+ || ( app-text/dos2unix app-text/hd2u )
+ sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ virtual/ada"
+
+src_prepare() {
+ rm "${S}"/MIME-tool/mime-tool || die
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "make failed"
+}
+
+src_install() {
+ emake install \
+ INSTALLPATH="${D}"/usr \
+ INSTALLPATHDOC="${D}"/usr/share/doc/${PF} \
+ || die "make install failed"
+ dohtml "${S}"/README.html || die
+}