summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSascha Lucas <sascha_lucas@web.de>2008-12-22 19:54:40 +0100
committerSascha Lucas <sascha_lucas@web.de>2008-12-22 19:54:40 +0100
commitce04c3fe5dd467cb4b9aecf1ab6c03f3c590af59 (patch)
treed1096925fd879fb22c756fed5133fb99b006cf8c
parentintroduced $CHAPPA_PL (diff)
downloadnet-mail-ce04c3fe5dd467cb4b9aecf1ab6c03f3c590af59.tar.gz
net-mail-ce04c3fe5dd467cb4b9aecf1ab6c03f3c590af59.tar.bz2
net-mail-ce04c3fe5dd467cb4b9aecf1ab6c03f3c590af59.zip
temporary fixed --as-needed
-rw-r--r--mail-client/alpine/Manifest4
-rw-r--r--mail-client/alpine/alpine-2.00.ebuild25
2 files changed, 17 insertions, 12 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index 0b46e65..3cc91fc 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,4 +1,4 @@
-DIST alpine-2.00-chappa-17-all.patch.gz 176061 RMD160 9b6e8a5f404e1e6c62ba2a0077fe8a280acb4505 SHA1 1e072422ae6eb70db976a584e6c93fbee40331c7 SHA256 68cf2e70944cc44c0be2e3a3ebb93eaf3e81008a305c14c9632399e69be9d050
+DIST alpine-2.00-chappa-18-all.patch.gz 176541 RMD160 9d3349bcba3b6a87ae326c81efc2b2d79dbd5143 SHA1 39b82ed964afe49f9f4a1f3347446d76b150d2c1 SHA256 4847cc6d447c776639b17bb104ee7cd53be7e81cd72a29f4c8cf520354d652d4
DIST alpine-2.00.tar.bz2 5222673 RMD160 9e67704b23b3973d8b878e65ad9e6f5026c10d13 SHA1 dcbd3c5419954f484ccf706feaba31ce48cdebc4 SHA256 c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6
-EBUILD alpine-2.00.ebuild 3800 RMD160 d91e7bce8c3f234672b6cd97917145b0f77db092 SHA1 fe8c515225e601f20236c102e6459ba9bbb07bc4 SHA256 f2ce6c3b73df0702f6de802df32843609b47f7714db164648514f141f20667ce
+EBUILD alpine-2.00.ebuild 3967 RMD160 244047da823339dc78fcd50cb0ff54663cdcbb3a SHA1 83a09d703a4fef54aa76e22864e062d0213832e2 SHA256 6e4929db62bdfbbf542bcf664638a93ec5d8e7024269a83bc4a3c778b34aa5fe
MISC metadata.xml 640 RMD160 c119e031ce500620da76dfcf67328e05f292c1c6 SHA1 6fc3b455d4cc83a601efd669a8c9f1c2641a6304 SHA256 5b19a81befa59e196971e823b86d26ff711c58240b0bcae0bcf5076a3133a6d2
diff --git a/mail-client/alpine/alpine-2.00.ebuild b/mail-client/alpine/alpine-2.00.ebuild
index 9ee3db9..e146775 100644
--- a/mail-client/alpine/alpine-2.00.ebuild
+++ b/mail-client/alpine/alpine-2.00.ebuild
@@ -4,10 +4,10 @@
EAPI="2"
-inherit eutils
+inherit eutils flag-o-matic
# http://staff.washington.edu/chappa/alpine/patches/${P}/log.txt
-CHAPPA_PL="17"
+CHAPPA_PL="18"
DESCRIPTION="alpine is an easy to use text-based based mail and news client"
HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/"
@@ -67,13 +67,6 @@ src_configure() {
--with-ssl-certs-dir=/etc/ssl/certs"
# fixme
# --with-system-mail-directory=DIR?
- # smime should be off if topal is on
- # fixme
- # --as-needed breaks linking of c-client for executables
- # filter-ldflags --as-needed does not work for
- # "-Wl,-O1,--as-needed,-z,now" ??
- #LDFLAGS=`echo $LDFLAGS | sed s/--as-needed//g | sed s/,,/,/g`
- #econf ${myconf} LDFLAGS="$LDFLAGS" || die "configure problem"
econf $(use_with ssl) \
$(use_with ldap) \
$(use_with passfile passfile .pinepwd) \
@@ -82,7 +75,7 @@ src_configure() {
$(use_with spell interactive-spellcheck /usr/bin/aspell) \
$(use_enable nls) \
$(use_with ipv6) \
- $(use_with smime) \
+ $(use topal || use_with smime) \
${myconf} || die "configure problem"
}
@@ -117,6 +110,18 @@ src_install() {
fi
}
+pkg_setup() {
+ if use smime && use topal ; then
+ ewarn "You can not have USE='smime topal'. Assuming topal is more important."
+ fi
+ # untill someone finds the right solution, we filter --as-needed
+ # see http://www.gentoo.org/proj/en/qa/asneeded.xml section "Importance of linking order"
+ # it seems that "-lpam -ldl -lcrypto" get fed into link command to early
+ # imap/src/osdep/unix/Makefile
+ # imap/Makefile
+ append-ldflags -Wl,--no-as-needed
+}
+
pkg_postinst() {
use chappa && maildir_warn
if use spell; then