aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-02-28 20:38:37 +0000
committerJustin Lecher <jlec@gentoo.org>2017-02-28 20:55:03 +0000
commitd6b88a10f2424e12ee35bf2fee0b75a84511d7e5 (patch)
tree36a8d604a3df4826a64a24790635f85aa82ca4a2
parentdev-libs/fortrancl: Bump to EAPI=6 (diff)
downloadsci-d6b88a10f2424e12ee35bf2fee0b75a84511d7e5.tar.gz
sci-d6b88a10f2424e12ee35bf2fee0b75a84511d7e5.tar.bz2
sci-d6b88a10f2424e12ee35bf2fee0b75a84511d7e5.zip
sci-astronomy/galfit-bin: QA fixes
Bump to EAPI=6 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-astronomy/galfit-bin/galfit-bin-3.0.5.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sci-astronomy/galfit-bin/galfit-bin-3.0.5.ebuild b/sci-astronomy/galfit-bin/galfit-bin-3.0.5.ebuild
index dd34a362d..86ec6a01b 100644
--- a/sci-astronomy/galfit-bin/galfit-bin-3.0.5.ebuild
+++ b/sci-astronomy/galfit-bin/galfit-bin-3.0.5.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
MYPN=galfit
-inherit multilib
-
DESCRIPTION="Galaxy morphology fitting program"
HOMEPAGE="http://users.obs.carnegiescience.edu/peng/work/galfit/galfit.html"
CURI="http://users.obs.carnegiescience.edu/peng/work/${MYPN}"
@@ -30,9 +28,9 @@ RESTRICT="mirror"
S="${WORKDIR}"
src_test() {
- chmod +x ${MYPN}
- cd ${MYPN}-example/EXAMPLE
- LD_LIBRARY_PATH=../.. ../../${MYPN} ${MYPN}.feedme
+ chmod +x ${MYPN} || die
+ cd ${MYPN}-example/EXAMPLE || die
+ LD_LIBRARY_PATH=../.. ../../${MYPN} ${MYPN}.feedme || die
}
src_install () {