aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2017-02-16 10:53:34 +0100
committerJustin Lecher <jlec@gentoo.org>2017-03-18 21:06:54 +0000
commit9819dadc1f41b04327d05561da751bb380071ba5 (patch)
tree999a26220ec6d255940074ee604b1822f36d8a79
parentOffline work (diff)
downloadsci-9819dadc1f41b04327d05561da751bb380071ba5.tar.gz
sci-9819dadc1f41b04327d05561da751bb380071ba5.tar.bz2
sci-9819dadc1f41b04327d05561da751bb380071ba5.zip
sci-biology/freebayes: force compilation in a single thread as parallel build fails
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-biology/freebayes/freebayes-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sci-biology/freebayes/freebayes-9999.ebuild b/sci-biology/freebayes/freebayes-9999.ebuild
index 896c4cfb7..1b1eb89ed 100644
--- a/sci-biology/freebayes/freebayes-9999.ebuild
+++ b/sci-biology/freebayes/freebayes-9999.ebuild
@@ -84,6 +84,10 @@ RDEPEND="${DEPEND}
# g++ -O3 -D_FILE_OFFSET_BITS=64 -g -I../ttmath -I../bamtools/src/ -I../vcflib/src/ -I../vcflib/tabixpp/ -I../vcflib/smithwaterman/ -I../vcflib/multichoose/ -I../vcflib/filevercmp/ -I../vcflib/tabixpp/htslib -I../SeqLib -I../SeqLib/htslib -c freebayes.cpp
+src_compile(){
+ emake -j1 # vcflib/smithwaterman/ sometimes does not compile
+}
+
src_install(){
dobin bin/freebayes bin/bamleftalign
}