summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-04-20 13:29:32 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-04-20 13:30:35 +0200
commit96f3d3c8939dbdf06c0e211d90729790898fca9e (patch)
tree83325d75921a2634cc727b161fcc84081fc95f9b /app-eselect
parentdev-python/werkzeug: Remove old (diff)
downloadgentoo-96f3d3c8939dbdf06c0e211d90729790898fca9e.tar.gz
gentoo-96f3d3c8939dbdf06c0e211d90729790898fca9e.tar.bz2
gentoo-96f3d3c8939dbdf06c0e211d90729790898fca9e.zip
app-eselect/eselect-java: add 0.5.1
Closes: https://bugs.gentoo.org/793965 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-java/Manifest1
-rw-r--r--app-eselect/eselect-java/eselect-java-0.5.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-eselect/eselect-java/Manifest b/app-eselect/eselect-java/Manifest
index 5e0c9321c52c..174ee098d1bf 100644
--- a/app-eselect/eselect-java/Manifest
+++ b/app-eselect/eselect-java/Manifest
@@ -1 +1,2 @@
DIST eselect-java-0.5.0.tar.bz2 14271 BLAKE2B dc285ad17b62043cc5085a586547a06a12c09f5a80f25dc423db9cb806baaa669a55106f605973fcae7103e35ec673ae2e3a6119730b1789e816a09079deabc8 SHA512 89724b96125911f0abc0363e0b2c9df75d0d52df1a5e16e80efa20a8de39b1bc0d411d297581b3440c944f498688e5dcffe5432f5e46836115d2eb620f31c03a
+DIST eselect-java-0.5.1.tar.bz2 14330 BLAKE2B a1333f2e1a40662cdca3ca6155f621efd4b4491fb83dd787d001b172d0baf6c960a217643a18dba5c262317613854cf62f79a9dbb0d621b2335499ada03cd03c SHA512 1a28667d635dae551b0432aa83e80b92733ed8a1c21c4d4a8d978c05e1e89034a0e073bd6fdf1f18569c48efbe17ad338bc95dde5b7e009ba87cad04f7e4a156
diff --git a/app-eselect/eselect-java/eselect-java-0.5.1.ebuild b/app-eselect/eselect-java/eselect-java-0.5.1.ebuild
new file mode 100644
index 000000000000..401e394906bb
--- /dev/null
+++ b/app-eselect/eselect-java/eselect-java-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A set of eselect modules for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="app-admin/eselect"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ local REMOVED=0
+
+ rm -v "${EROOT}"/usr/lib*/nsbrowser/plugins/javaplugin.so 2>/dev/null && REMOVED=1
+ rm -v "${EROOT}"/etc/java-config-2/current-icedtea-web-vm 2>/dev/null && REMOVED=1
+
+ if [[ ${REMOVED} = 1 ]]; then
+ elog "The eselect java-nsplugin module has been removed and your configuration"
+ elog "has been cleaned up. From now on, you may only install either Oracle or"
+ elog "IcedTea's plugin but not both. Note you can use IcedTea's plugin with an"
+ elog "Oracle VM. See the README installed with icedtea-web for more details."
+ fi
+}