summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-09-09 22:53:33 +0200
committerSam James <sam@gentoo.org>2024-09-09 22:08:14 +0100
commitdcbc9870f4abce2fa59c266f94c10b546071ba49 (patch)
treedbc120e896b7dd9195dd450e5c397d0ead3cc5fa /dev-debug
parentdev-python/gdb-pt-dump: sync live (diff)
downloadgentoo-dcbc9870f4abce2fa59c266f94c10b546071ba49.tar.gz
gentoo-dcbc9870f4abce2fa59c266f94c10b546071ba49.tar.bz2
gentoo-dcbc9870f4abce2fa59c266f94c10b546071ba49.zip
dev-debug/pwndbg: add 20240829
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/pwndbg/Manifest1
-rw-r--r--dev-debug/pwndbg/pwndbg-20240829.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-debug/pwndbg/Manifest b/dev-debug/pwndbg/Manifest
index 838c10a82a44..1c1bb274e7ab 100644
--- a/dev-debug/pwndbg/Manifest
+++ b/dev-debug/pwndbg/Manifest
@@ -1,3 +1,4 @@
DIST gdb-pt-dump-ebdc24573a4bf075cf3ab6016add9db6baacf977.tar.gz 385989 BLAKE2B b7582289f83fd0c76b8ef2a04540db979b0f599b6b711e17541e2804b93bcffe6fd611d43101c96644a7324398eea5df02326267b4e201564929de956849b719 SHA512 57701b5fdd4c69be79a451f08fa6d7cbd43a0963cfd7689443676b68ece96154ccb61121d4a770d6e519d3142f99c589df1143b0ff8308547c06fb0e87e187db
DIST pwndbg-20230717.tar.gz 8392017 BLAKE2B e373a7408366090f58385dac8dfcdd13702c475117a35158a1a149d149c9a2cbf5f2702be33aeab537451cfd990b5253e9bc0283fa5ae197c9cceb680e65a724 SHA512 d261ed992327d62b0b3e7cc002d3185435748e27cc2ce0085d438848ef1bdb0b3921ae5c1ce19c25e49d52b10f8340eb67c4e05fc197d2adeb888b47e2c158ba
DIST pwndbg-20240214.tar.gz 8536795 BLAKE2B 75524fb9f701769f2a117b4aa1158f648cd854fd38475c20bee4b7ae27ae8f331c40367738a467dd5c7f8994ac80efd3290a64e59ffb9e5a240546be8fb1c6e8 SHA512 3d55e762cecd2b42b9debb36f3ee0a8983be744192d4c1a0424517b0fd8ae8fb329197228a88ddd726e640f1bcd0e0bcdc7e95a64e041630e20cfcbf6acff1aa
+DIST pwndbg-20240829.tar.gz 8649207 BLAKE2B 5333c318ba3ccbaaac459f9c7b917d3defa1ad712f45555b31eb76774089e55e80720744dc92813ad8234302445e3bed3237c2275c795a49856028dec416dcc2 SHA512 503924742d4a6d767ec369bb1e37c931afb5ab09f2b4cfa048765ce7a61fb6adcda2576cdda64dd4cf74de27d83b13b4dc09d6e7480e01ae8f646c5394992d43
diff --git a/dev-debug/pwndbg/pwndbg-20240829.ebuild b/dev-debug/pwndbg/pwndbg-20240829.ebuild
new file mode 100644
index 000000000000..d15962d258f3
--- /dev/null
+++ b/dev-debug/pwndbg/pwndbg-20240829.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 wrapper
+
+DESCRIPTION="A GDB plug-in that makes debugging with GDB suck less"
+HOMEPAGE="https://github.com/pwndbg/pwndbg"
+
+if [[ ${PV} == "99999999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pwndbg/pwndbg"
+else
+ MY_PV="${PV:0:4}.${PV:4:2}.${PV:6:2}"
+ SRC_URI="https://github.com/pwndbg/pwndbg/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
+ ~dev-python/gdb-pt-dump-0.0.0_p20240401[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-libs/capstone-5.0.2[python,${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.8[${PYTHON_USEDEP}]
+ >=dev-python/pycparser-2.22[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.29[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.32.3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.12.0[${PYTHON_USEDEP}]
+ >=dev-util/pwntools-4.13.0[${PYTHON_USEDEP}]
+ >=dev-util/ROPgadget-7.3[${PYTHON_USEDEP}]
+ >=dev-util/unicorn-2.0.1[python,${PYTHON_USEDEP}]
+ ')
+"
+
+# Tests are architectur-specific (precompiled binaries)
+RESTRICT="test"
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/${PN}
+ doins gdbinit.py
+
+ # Signal pwndbg not to create it's own python venv (Bug #918705).
+ # See: https://github.com/pwndbg/pwndbg/commit/139b7542cd9567eaff32bd713df971b6ac5b81de
+ touch "${ED}/usr/share/${PN}/.skip-venv" || die
+
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper "pwndbg" \
+ "gdb -x \"${EPREFIX}/usr/share/${PN}/gdbinit.py\"" || die
+
+ dodoc {README,DEVELOPING,FEATURES}.md
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ einfo "\nUsage:"
+ einfo " ~$ pwndbg <program>"
+ ewarn "\nWARNING!!!"
+ ewarn "Some pwndbg commands only works with libc debug symbols.\n"
+ ewarn "See also:"
+ ewarn " * https://github.com/pentoo/pentoo-overlay/issues/521#issuecomment-548975884"
+ ewarn " * https://sourceware.org/gdb/onlinedocs/gdb/Separate-Debug-Files.html"
+ ewarn " * https://wiki.gentoo.org/wiki/Debugging"
+ fi
+}