summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-14 21:55:41 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-14 22:32:33 +0000
commit589f90b27ca352eb565e74513068d9f243e6a384 (patch)
tree412e22da27d2c6f0edb2d755e8fa33c82e85751c /dev-python/diskcache
parentdev-python/girder-client: initial import (diff)
downloadgentoo-589f90b27ca352eb565e74513068d9f243e6a384.tar.gz
gentoo-589f90b27ca352eb565e74513068d9f243e6a384.tar.bz2
gentoo-589f90b27ca352eb565e74513068d9f243e6a384.zip
dev-python/diskcache: initial import
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest1
-rw-r--r--dev-python/diskcache/diskcache-2.8.3.ebuild41
-rw-r--r--dev-python/diskcache/metadata.xml12
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
new file mode 100644
index 000000000000..fe362d8d1e4e
--- /dev/null
+++ b/dev-python/diskcache/Manifest
@@ -0,0 +1 @@
+DIST diskcache-2.8.3.tar.gz 438587 SHA256 61ccc77a51a3e3b31abfb80de7163ba51ce09b1612e0d026f1c0457575c23002 SHA512 d96ac76dfb68cb817febd3f4ed8927a8409c02b13b4112a739528cade40f9a588c732dfc3148392dd12676380c3a2b006ee63b86f30ad70f5d205273003bf23d WHIRLPOOL 0ad78c98a64ae59661eb08c842cb363b42f076e856c1eca8c516bb6b14856c6391afc8a2d5e01bfe0e20fe88e20b8967dbd7cda51785e13e7c6b1dd9947930fd
diff --git a/dev-python/diskcache/diskcache-2.8.3.ebuild b/dev-python/diskcache/diskcache-2.8.3.ebuild
new file mode 100644
index 000000000000..8dba94ae6c0a
--- /dev/null
+++ b/dev-python/diskcache/diskcache-2.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "failed with ${PYTHON}"
+}
diff --git a/dev-python/diskcache/metadata.xml b/dev-python/diskcache/metadata.xml
new file mode 100644
index 000000000000..bda6b340bb5b
--- /dev/null
+++ b/dev-python/diskcache/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">diskcache</remote-id>
+ <remote-id type="github">grantjenks/python-diskcache</remote-id>
+ </upstream>
+</pkgmetadata>