summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-25 23:20:46 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-25 23:20:46 +0200
commit62d0c0f7a728ebd4a1201755b3c3fb4b68a10aec (patch)
treebc17c317a9fe55ffe9354b856e5ed7ae5df2ce59 /dev-python/jaraco-stream
parentdev-python/jaraco-itertools: add Python 3.7, more verbose tests (diff)
downloadgentoo-62d0c0f7a728ebd4a1201755b3c3fb4b68a10aec.tar.gz
gentoo-62d0c0f7a728ebd4a1201755b3c3fb4b68a10aec.tar.bz2
gentoo-62d0c0f7a728ebd4a1201755b3c3fb4b68a10aec.zip
dev-python/jaraco-stream: add Python 3.7, more verbose tests
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/jaraco-stream')
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.2.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.2.ebuild
index 8aa4e6c40820..b990da9621d0 100644
--- a/dev-python/jaraco-stream/jaraco-stream-1.2.ebuild
+++ b/dev-python/jaraco-stream/jaraco-stream-1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -47,7 +47,7 @@ python_compile_all() {
python_test() {
# Skip one test which requires network access
# Override pytest options to skip flake8
- PYTHONPATH=. py.test --ignore=jaraco/stream/test_gzip.py \
+ PYTHONPATH=. pytest -vv --ignore=jaraco/stream/test_gzip.py \
--override-ini="addopts=--doctest-modules" \
|| die "tests failed with ${EPYTHON}"
}