summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-03-24 20:54:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-03-24 22:05:53 +0300
commit039c4f6b4a23e09670c4bd749d693b8c97c0e20b (patch)
treecc4fccf6f6f7d7c8e87b5730646d12fad95a6b62 /dev-python/pyghmi
parentdev-python/pygobject: add 3.44.1 (diff)
downloadgentoo-039c4f6b4a23e09670c4bd749d693b8c97c0e20b.tar.gz
gentoo-039c4f6b4a23e09670c4bd749d693b8c97c0e20b.tar.bz2
gentoo-039c4f6b4a23e09670c4bd749d693b8c97c0e20b.zip
dev-python/pyghmi: add 1.5.60
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.60.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 20d97f05cac0..25fc49c6a2c8 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1 +1,2 @@
DIST pyghmi-1.5.59.tar.gz 251390 BLAKE2B 0299bf92e6252e21499172e9d4389ecd2a19912ddb9cf9cd8769fc6dd994536526f909711975af58a01169ec2aa20eabba5ca20a5f66ddaaf948be9c1f77060c SHA512 adb64a400a53a17d8837972220807b9bc6f00291316c2f28a45f56d7f9fbaaa8775002e37eeb12e96445636c7a0a25c2829f4ee6c9ffa4c52a83fb35d5391b47
+DIST pyghmi-1.5.60.tar.gz 251748 BLAKE2B 8e860847293db5b747144b3f5e21690c898ebc80c5de8c24dac169b38653893c90b80b0820d3acb5309e95e934cb75e8390b9b5f65e08513a1bd0b62ee62fe9f SHA512 a75528fea803ec68ae12f34befc7d95072baa1bffb8a60d62ebccf41b62f5bdbb510d1b11d9f31ddcc82830ebdc3b31ef6d51b5bca16c89be5dd450cd0a1f82e
diff --git a/dev-python/pyghmi/pyghmi-1.5.60.ebuild b/dev-python/pyghmi/pyghmi-1.5.60.ebuild
new file mode 100644
index 000000000000..7b3d2e7d3897
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.60.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="
+ https://opendev.org/x/pyghmi/
+ https://pypi.org/project/pyghmi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest