summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 16:32:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 16:32:06 +0200
commit730941d4469c1b802f8e2980b4f83f71641e42d3 (patch)
tree5a620f6408d51cc1c9e5c8891e06a670263fb181 /dev-python/pytest-skip-markers
parentdev-python/mapbox-earcut: Remove old (diff)
downloadgentoo-730941d4469c1b802f8e2980b4f83f71641e42d3.tar.gz
gentoo-730941d4469c1b802f8e2980b4f83f71641e42d3.tar.bz2
gentoo-730941d4469c1b802f8e2980b4f83f71641e42d3.zip
dev-python/pytest-skip-markers: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-skip-markers')
-rw-r--r--dev-python/pytest-skip-markers/Manifest1
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/pytest-skip-markers/Manifest b/dev-python/pytest-skip-markers/Manifest
index d48baf75e0c2..830a3c2d8ab5 100644
--- a/dev-python/pytest-skip-markers/Manifest
+++ b/dev-python/pytest-skip-markers/Manifest
@@ -1,2 +1 @@
-DIST pytest-skip-markers-1.5.1.gh.tar.gz 73219 BLAKE2B f8f23bf64dfc23263ee58397fa8571bf76a77820230f8f27003f72f0a26cbb19ae76185ed203e5b516326a40a355c2d006101f2eb7cd4df40f4a4d80e8e7c629 SHA512 4221e39ab472a88c4f6d0cf2fbf0de1568f99f5ca9962e4afab060b6cfd8365d106583cf818a98bbc7f8f4d5192c7fc9678e4e0da2b6c1082c26ee2e049b0004
DIST pytest-skip-markers-1.5.2.gh.tar.gz 73513 BLAKE2B 51eb60d13a4b91030f68cf95cf1cb1987cc77bc105355fbceb289e73412f577347ba0340403e32b7930c08945b4d0292b7eededc84e8a5932c457073c823be1e SHA512 631cc632dc3d56cc9a62253f50897b98305402516faa2cf10fce8099069618bc82d281ddf1bf5e89ce8e62b798a8391a09132ec493199f3a86e8681c7062b58f
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild
deleted file mode 100644
index df299f464d59..000000000000
--- a/dev-python/pytest-skip-markers/pytest-skip-markers-1.5.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
-HOMEPAGE="
- https://pytest-skip-markers.readthedocs.io/en/latest/
- https://github.com/saltstack/pytest-skip-markers
-"
-SRC_URI="
- https://github.com/saltstack/pytest-skip-markers/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/pyfakefs[${PYTHON_USEDEP}]
- dev-python/pytest-subtests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytestskipmarkers.plugin,pyfakefs.pytest_plugin
- epytest
-}