summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/detex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/detex')
-rw-r--r--dev-tex/detex/Manifest1
-rw-r--r--dev-tex/detex/detex-2.8-r1.ebuild41
-rw-r--r--dev-tex/detex/files/detex-2.8-ldflags.patch17
-rw-r--r--dev-tex/detex/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-tex/detex/Manifest b/dev-tex/detex/Manifest
new file mode 100644
index 000000000000..da7ae3dbe7f5
--- /dev/null
+++ b/dev-tex/detex/Manifest
@@ -0,0 +1 @@
+DIST detex-2.8.tar 318976 SHA256 13ad67311f232faa31da9fa8322645c5745e8ed5ab977cc85818154fabd94134 SHA512 5afd54aebc3a018e9b72a5e5f37d05858b0b90c1165ec725b08995f5338479153a04ff938a2f54543108c66ac2f66d2c06159d331c9cde304ebce32b527c737f WHIRLPOOL cf6e3c7106a2e108105180e09385a208b6970ca72dc19498832d4fa07dcb866efb04f8528a0d83263090af7c7ca9feaa91cb767a35f39af89581753a9cf059f9
diff --git a/dev-tex/detex/detex-2.8-r1.ebuild b/dev-tex/detex/detex-2.8-r1.ebuild
new file mode 100644
index 000000000000..cd897df70cdc
--- /dev/null
+++ b/dev-tex/detex/detex-2.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A filter program that removes the LaTeX (or TeX) control sequences"
+HOMEPAGE="http://www.cs.purdue.edu/homes/trinkle/detex/"
+SRC_URI="http://www.cs.purdue.edu/homes/trinkle/detex/${P}.tar"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ sed -i \
+ -e "s:CFLAGS = -O \${DEFS}:CFLAGS = ${CFLAGS} \${DEFS}:" \
+ -e 's:LEX = lex:#LEX = lex:' \
+ -e 's:#LEX = flex:LEX = flex:' \
+ -e 's:#DEFS += ${DEFS} -DNO_MALLOC_DECL:DEFS += -DNO_MALLOC_DECL:' \
+ -e 's:LEXLIB = -ll:LEXLIB = -lfl:' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin detex || die
+ dodoc README
+ doman detex.1l
+}
diff --git a/dev-tex/detex/files/detex-2.8-ldflags.patch b/dev-tex/detex/files/detex-2.8-ldflags.patch
new file mode 100644
index 000000000000..e70c000b0c5b
--- /dev/null
+++ b/dev-tex/detex/files/detex-2.8-ldflags.patch
@@ -0,0 +1,17 @@
+dont ignore ldflags
+bug #209731
+
+
+Index: detex-2.8/Makefile
+===================================================================
+--- detex-2.8.orig/Makefile
++++ detex-2.8/Makefile
+@@ -104,7 +104,7 @@ D_OBJ = detex.o
+ all: ${PROGS}
+
+ detex: ${D_OBJ}
+- ${CC} ${CFLAGS} -o $@ ${D_OBJ} ${LEXLIB}
++ ${CC} $(LDFLAGS) ${CFLAGS} -o $@ ${D_OBJ} ${LEXLIB}
+
+ detex.c:
+ sed -f states.sed detex.l > xxx.l
diff --git a/dev-tex/detex/metadata.xml b/dev-tex/detex/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/detex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>