summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-mud/mudix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-mud/mudix')
-rw-r--r--games-mud/mudix/Manifest1
-rw-r--r--games-mud/mudix/files/mudix-4.3-as-needed.patch11
-rw-r--r--games-mud/mudix/metadata.xml5
-rw-r--r--games-mud/mudix/mudix-4.3-r1.ebuild32
4 files changed, 49 insertions, 0 deletions
diff --git a/games-mud/mudix/Manifest b/games-mud/mudix/Manifest
new file mode 100644
index 000000000000..9d624e7de856
--- /dev/null
+++ b/games-mud/mudix/Manifest
@@ -0,0 +1 @@
+DIST mudix-4.3.tar.gz 43003 SHA256 91b5946fd09381135a226b3298298d67325b01f79a9ccb5641137376171fb680 SHA512 9f9c8ee43ded9b837eb50e463e67b666e0b2b34334d93e9a4471fa792da99350042cd8abbd9f8e97aa7ba114736b2d99c1b6595c76a5254270a514681130eb94 WHIRLPOOL 110753eeaf60003e9185032f4f581061f65d0fb2659f6aa4d6ca0fc183d5c49402a4f5623744fa41176d2553b2842b811ee5bd5ee499c42d5b5987f2e825fac8
diff --git a/games-mud/mudix/files/mudix-4.3-as-needed.patch b/games-mud/mudix/files/mudix-4.3-as-needed.patch
new file mode 100644
index 000000000000..51f5cc4d74fa
--- /dev/null
+++ b/games-mud/mudix/files/mudix-4.3-as-needed.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in.old 2009-02-08 17:32:15.000000000 +0100
++++ src/Makefile.in 2009-02-08 17:34:15.000000000 +0100
+@@ -23,7 +23,7 @@
+
+ $(EXEC): $(O_FILES)
+ rm -f $(EXEC)
+- $(CC) -o $(EXEC) $(L_FLAGS) $(O_FILES)
++ $(CC) -o $(EXEC) $(LDFLAGS) $(O_FILES) $(L_FLAGS)
+
+ .c.o: mudix.h conf.h
+ $(CC) -c $(C_FLAGS) $<
diff --git a/games-mud/mudix/metadata.xml b/games-mud/mudix/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-mud/mudix/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-mud/mudix/mudix-4.3-r1.ebuild b/games-mud/mudix/mudix-4.3-r1.ebuild
new file mode 100644
index 000000000000..d47ab9f56e86
--- /dev/null
+++ b/games-mud/mudix/mudix-4.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A small, stable MUD client for the console"
+HOMEPAGE="http://dw.nl.eu.org/mudix.html"
+SRC_URI="http://dw.nl.eu.org/mudix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ emake -C src O_FLAGS="${CFLAGS}"
+}
+
+src_install () {
+ dogamesbin mudix
+ dodoc README sample.usr
+ prepgamesdirs
+}