summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 21:47:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:39 +0100
commitf45c0e288f49b4a491fa46d57b2b72e64ce2ad5a (patch)
treee33dbed838449ff792a573b89f2fe82a3ab5b0de /media-gfx/lximage-qt
parentapp-arch/lxqt-archiver: add version 0.3.0 (diff)
downloadgentoo-f45c0e288f49b4a491fa46d57b2b72e64ce2ad5a.tar.gz
gentoo-f45c0e288f49b4a491fa46d57b2b72e64ce2ad5a.tar.bz2
gentoo-f45c0e288f49b4a491fa46d57b2b72e64ce2ad5a.zip
media-gfx/lximage-qt: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/lximage-qt')
-rw-r--r--media-gfx/lximage-qt/Manifest1
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.16.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/Manifest b/media-gfx/lximage-qt/Manifest
index a21325a9b9f4..685c4972bfde 100644
--- a/media-gfx/lximage-qt/Manifest
+++ b/media-gfx/lximage-qt/Manifest
@@ -1 +1,2 @@
DIST lximage-qt-0.15.0.tar.xz 91444 BLAKE2B a5ccd9afdd4ed1ec60a5da8ec3390e5d93f018209ce62a1fbf929c6984a056539751f576a15e0b81e4f1ba003d35379791066832f02a45de1a5d5e8e8eb8f0b2 SHA512 980fc401b31c5d937877ef35211892984def150a6db6072d9752fa78588ea8ca0827beb5880d46775092c42e93358d3e494e045a50756931129402ded4ecab23
+DIST lximage-qt-0.16.0.tar.xz 100920 BLAKE2B 17a41013b7d7e599662a698fa24b6b15a550b2211dd818fbfda19b0fb9439bf77b63b2d8248ad8a65605fee8fc73c78d294ae86401d5660f6d798aa775273709 SHA512 2da46d23567cff7044a884e14b30de36b3a19d802768585b7c3332897b0af2fc42993ed9bb9d062db7988a0526cc7357a09fbac5f283a615b109ea8dfbf474b5
diff --git a/media-gfx/lximage-qt/lximage-qt-0.16.0.ebuild b/media-gfx/lximage-qt/lximage-qt-0.16.0.ebuild
new file mode 100644
index 000000000000..9fc843665a0f
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.16.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Image Viewer"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libexif
+ >=x11-libs/libfm-qt-0.16.0:=
+ x11-libs/libX11
+ x11-libs/libXfixes
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}