summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-05 03:20:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-05 03:20:31 +0200
commit561792d7b7fb11a0fe2c1b566dcdb0d2204ebb78 (patch)
tree7743501cd3dea4dfacbf9ff01c74c676c623b51b /media-libs/libheif
parentsys-kernel/genkernel: fix boost SRC_URI (diff)
downloadgentoo-561792d7b7fb11a0fe2c1b566dcdb0d2204ebb78.tar.gz
gentoo-561792d7b7fb11a0fe2c1b566dcdb0d2204ebb78.tar.bz2
gentoo-561792d7b7fb11a0fe2c1b566dcdb0d2204ebb78.zip
media-libs/libheif: bump to v1.4.1
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-libs/libheif')
-rw-r--r--media-libs/libheif/Manifest1
-rw-r--r--media-libs/libheif/libheif-1.4.1.ebuild66
-rw-r--r--media-libs/libheif/libheif-9999.ebuild10
3 files changed, 76 insertions, 1 deletions
diff --git a/media-libs/libheif/Manifest b/media-libs/libheif/Manifest
index 4cdaac830c93..a4fd0ee7736e 100644
--- a/media-libs/libheif/Manifest
+++ b/media-libs/libheif/Manifest
@@ -1,2 +1,3 @@
DIST libheif-1.3.2.tar.gz 1328174 BLAKE2B 4c0f82bb90d48f89a4ce9aed525c5823bb5d008e54e580e761f6fa4f5493f265929a0607e7b81046ba7c249bd2ca21a0c5ab91da83b7e7f3a2a63e8f24df88ed SHA512 bcc8b4b2522ef6fe68f5a9ffd5312c2c8f6bc3718394eef1860e199c30fb735bb214f665ed6480b5f5fe5d578b3ed77a4301af93775ae2349ba5038b3f3ef63a
DIST libheif-1.4.0.tar.gz 1366030 BLAKE2B a93b3b59a4f89e0aa5a5069fdebc54b9d09adeeff05ebf28b9535baa2fb26e4122b4c5d96b7015fdd181720f10e3dd0887038f0c5567c94509aa76d2ef119dd9 SHA512 fc48caaadb71ffa87227de75c9e13d5006c66f1c966ce454552defb8947999f5242a9bbd1413f58be1ccbf61df7f118defe96d67376e3b4e7b12fe5dfa0fe0c7
+DIST libheif-1.4.1.tar.gz 950721 BLAKE2B 39793dbf4334b7ca93993ba518f9c935eb6d29a2debea12a3f1727d245572945e456b7997d79403da53bb5701ee62af8235a9815221402e5b901d9c07aa015a0 SHA512 c6e7d00c040885c506dde40469ba51b0346126689ed238abce123b471f748431cb29914015b3ca97749855a0f1f7c8e9a58388d4468da3c2d17c7a3a15270af0
diff --git a/media-libs/libheif/libheif-1.4.1.ebuild b/media-libs/libheif/libheif-1.4.1.ebuild
new file mode 100644
index 000000000000..26dca1d6a11a
--- /dev/null
+++ b/media-libs/libheif/libheif-1.4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools xdg-utils multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.4"
+IUSE="static-libs test +threads"
+
+BDEPEND="test? ( dev-lang/go )"
+DEPEND="
+ media-libs/libde265:=[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:-Werror::' \
+ configure.ac || die
+
+ eautoreconf
+
+ # prevent "stat heif-test.go: no such file or directory"
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable threads multithreading)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
index a03be0af6d3d..edd14c4d4016 100644
--- a/media-libs/libheif/libheif-9999.ebuild
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit autotools multilib-minimal
+inherit autotools xdg-utils multilib-minimal
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
@@ -56,3 +56,11 @@ multilib_src_install_all() {
find "${ED}" -name "*.a" -delete || die
fi
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}