summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-12-13 16:35:11 +1300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-15 12:40:31 +0100
commit62c564e6679094847603f21ffc1fd63a5345511c (patch)
treed3c6223758bd0cc7b9f523908e05967983ac1dcb /sci-libs/bliss/bliss-0.77.ebuild
parentkde-frameworks/plasma: Hide svg glitches using a smaller mask (diff)
downloadgentoo-62c564e6679094847603f21ffc1fd63a5345511c.tar.gz
gentoo-62c564e6679094847603f21ffc1fd63a5345511c.tar.bz2
gentoo-62c564e6679094847603f21ffc1fd63a5345511c.zip
sci-libs/bliss: New upstream release
Closes: https://bugs.gentoo.org/829119 Closes: https://github.com/gentoo/gentoo/pull/23284 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/bliss/bliss-0.77.ebuild')
-rw-r--r--sci-libs/bliss/bliss-0.77.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/bliss/bliss-0.77.ebuild b/sci-libs/bliss/bliss-0.77.ebuild
new file mode 100644
index 000000000000..88a4d042c220
--- /dev/null
+++ b/sci-libs/bliss/bliss-0.77.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+SRC_URI="https://users.aalto.fi/~tjunttil/${PN}/downloads/${P}.zip"
+DESCRIPTION="Compute Automorphism Groups and Canonical Labelings of Graphs"
+HOMEPAGE="https://users.aalto.fi/~tjunttil/bliss/index.html"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="gmp"
+
+RDEPEND="gmp? ( dev-libs/gmp:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+PATCHES=( "${FILESDIR}/${PN}-0.77-install.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GMP="$(usex gmp)"
+ )
+
+ cmake_src_configure
+}