summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 15:15:55 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 15:15:55 +0200
commit8dc26a90c1f885be27e37e59d752b690ee919264 (patch)
treec6b508de4b626ea7b9858395786d0e0f818f2c69 /sys-fs/multipath-tools
parentdev-python/pyalsa: Stabilize 1.2.7 ppc, #855794 (diff)
downloadgentoo-8dc26a90c1f885be27e37e59d752b690ee919264.tar.gz
gentoo-8dc26a90c1f885be27e37e59d752b690ee919264.tar.bz2
gentoo-8dc26a90c1f885be27e37e59d752b690ee919264.zip
sys-fs/multipath-tools: add 0.9.0
Bug: https://bugs.gentoo.org/852173 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/Manifest1
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch15
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.9.0.ebuild76
3 files changed, 92 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/Manifest b/sys-fs/multipath-tools/Manifest
index 55dc9b865d23..480f8d568d21 100644
--- a/sys-fs/multipath-tools/Manifest
+++ b/sys-fs/multipath-tools/Manifest
@@ -1 +1,2 @@
DIST multipath-tools-0.8.9.tar.gz 534866 BLAKE2B b5ebf3c393f6b60e85678ac07378ae07056b6777409fc1bc4f4133cdd3f8c75a3d76f6e9342208df7fed8fe7812b089eba8f6b769e47e1dd6c8b7fd321bdbd30 SHA512 25f2a5d436af6a343804988cef45ca1574d4a981655a2b91563ddb89138619158befdf5af92d836a17c95d6dcf901072b614473c2129274e5dcdb1a1d64edb4d
+DIST multipath-tools-0.9.0.tar.gz 537311 BLAKE2B e7d4958d24d1e19da2b80be23585ad37f6b0c1b66dc1377014d825ddd2be10ea3b8c30162cb7a23b120427bf0c957c6cad8560018e1cb058c284f37afd5d50d4 SHA512 6c417f6d1d116fa43bedb9f77769ece9cbb7b35b78a9b3558c41df2360e52a65a07314b12ab7e4a7bbc867b9755250de9db96a2f7eb4a6a37f0b0b3f0bbc840e
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch b/sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch
new file mode 100644
index 000000000000..f2b6dca05776
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch
@@ -0,0 +1,15 @@
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -140,10 +140,9 @@
+ WARNFLAGS := -Werror -Wall -Wextra -Wformat=2 $(WFORMATOVERFLOW) -Werror=implicit-int \
+ -Werror=implicit-function-declaration -Werror=format-security \
+ $(WNOCLOBBERED) -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS)
+-CPPFLAGS := $(FORTIFY_OPT) \
+- -DBIN_DIR=\"$(bindir)\" -DMULTIPATH_DIR=\"$(plugindir)\" -DRUN_DIR=\"${RUN}\" \
++CPPFLAGS += -DBIN_DIR=\"$(bindir)\" -DMULTIPATH_DIR=\"$(plugindir)\" -DRUN_DIR=\"${RUN}\" \
+ -DCONFIG_DIR=\"$(configdir)\" -DEXTRAVERSION=\"$(EXTRAVERSION)\" -MMD -MP
+-CFLAGS := --std=gnu99 $(CFLAGS) $(OPTFLAGS) $(WARNFLAGS) -pipe
++CFLAGS += -std=gnu99 $(WARNFLAGS)
+ BIN_CFLAGS = -fPIE -DPIE
+ LIB_CFLAGS = -fPIC
+ SHARED_FLAGS = -shared
diff --git a/sys-fs/multipath-tools/multipath-tools-0.9.0.ebuild b/sys-fs/multipath-tools/multipath-tools-0.9.0.ebuild
new file mode 100644
index 000000000000..c3ba08e79c7e
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.9.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd toolchain-funcs udev
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="https://github.com/opensvc/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/json-c:=
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ >=sys-fs/lvm2-2.02.45
+ >=virtual/libudev-232-r3
+ sys-libs/readline:=
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~DM_MULTIPATH"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.0-respect-flags.patch )
+
+src_compile() {
+ tc-export CC
+
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake \
+ prefix="${EPREFIX}" \
+ LIB="$(get_libdir)" \
+ LIBDM_API_FLUSH=1 \
+ PKGCONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man{3,5,8}
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}" \
+ LIB="$(get_libdir)" \
+ RUN=run \
+ unitdir="$(systemd_get_systemunitdir)" \
+ libudevdir='$(prefix)'/$(get_udevdir) \
+ pkgconfdir='$(prefix)/usr/$(LIB)/pkgconfig' \
+ install
+ einstalldocs
+
+ newinitd "${FILESDIR}"/multipathd-r1.rc multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ udev_reload
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}