summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-20 21:51:32 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-20 21:51:32 +0100
commit0757cad23c206d70aedabfbf88396ee135e76da8 (patch)
tree5f70e4d3ce8093204d548e33d8363178d983d274 /x11-drivers
parentvirtual/commonlisp: update EAPI 6 -> 8 (diff)
downloadgentoo-0757cad23c206d70aedabfbf88396ee135e76da8.tar.gz
gentoo-0757cad23c206d70aedabfbf88396ee135e76da8.tar.bz2
gentoo-0757cad23c206d70aedabfbf88396ee135e76da8.zip
x11-drivers/xf86-input-mtrack: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-mtrack/xf86-input-mtrack-0.5.0-r1.ebuild (renamed from x11-drivers/xf86-input-mtrack/xf86-input-mtrack-0.5.0.ebuild)18
1 files changed, 8 insertions, 10 deletions
diff --git a/x11-drivers/xf86-input-mtrack/xf86-input-mtrack-0.5.0.ebuild b/x11-drivers/xf86-input-mtrack/xf86-input-mtrack-0.5.0-r1.ebuild
index 7d85cca0f2b7..827742b72b77 100644
--- a/x11-drivers/xf86-input-mtrack/xf86-input-mtrack-0.5.0.ebuild
+++ b/x11-drivers/xf86-input-mtrack/xf86-input-mtrack-0.5.0-r1.ebuild
@@ -1,41 +1,39 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit vcs-snapshot
DESCRIPTION="Xorg Driver for Multitouch Trackpads"
HOMEPAGE="https://github.com/p2rkw/xf86-input-mtrack"
SRC_URI="https://github.com/p2rkw/xf86-input-mtrack/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
-IUSE="debug"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
+IUSE="debug"
-RDEPEND=">=sys-libs/mtdev-1.0
+RDEPEND="
+ >=sys-libs/mtdev-1.0
x11-base/xorg-server:="
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-DOCS=( "README.md" )
-
src_configure() {
- econf \
- $(use_enable debug)
+ econf $(use_enable debug)
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
elog
elog "To enable multitouch support add the following lines"
elog "to your xorg.conf:"
- elog ""
+ elog
elog "Section \"InputClass\""
elog " MatchIsTouchpad \"true\""
elog " Identifier \"Touchpads\""