summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaide <github@maide.ca>2024-08-10 18:00:51 -0400
committerMatt Turner <mattst88@gentoo.org>2024-08-12 11:31:11 -0400
commit61309a4ab7a675175279172ab0ad4ee2b62881d9 (patch)
tree68b34fbd1e5d62cb2803c3776ba71a2396442603 /x11-misc/xkeyboard-config
parentsys-block/fio: add 3.37 (diff)
downloadgentoo-61309a4ab7a675175279172ab0ad4ee2b62881d9.tar.gz
gentoo-61309a4ab7a675175279172ab0ad4ee2b62881d9.tar.bz2
gentoo-61309a4ab7a675175279172ab0ad4ee2b62881d9.zip
x11-misc/xkeyboard-config: Enforce >= python3_11 dependency
Python is now always listed as a dependency, as `xkeyboard-config` uses python during the build process whether or not the `test` USE flag is set. Always call `python-any-r1_pkg_setup` during package setup so that the `PYTHON_COMPAT` value is used/enforced. This fixes a build error if the system's default python is an incompatible version. Updated trivial homepage url change pkgcheck complained about. Closes: https://bugs.gentoo.org/936137 Closes: https://bugs.gentoo.org/933984 Signed-off-by: Maide <github@maide.ca> Closes: https://github.com/gentoo/gentoo/pull/38089 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild6
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild
index d745fe878f9f..3d57d234a633 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.42.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{11..12} )
inherit meson python-any-r1
DESCRIPTION="X keyboard configuration database"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig/ https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
@@ -26,8 +26,8 @@ BDEPEND="
dev-lang/perl
dev-libs/libxslt
sys-devel/gettext
+ ${PYTHON_DEPS}
test? (
- ${PYTHON_DEPS}
x11-apps/xkbcomp
x11-libs/libxkbcommon
$(python_gen_any_dep '
@@ -47,7 +47,7 @@ python_check_deps() {
}
pkg_setup() {
- use test && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
}
src_prepare() {
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
index 9ae1caa1e13b..f0a2c00dbf40 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{11..12} )
inherit meson python-any-r1
DESCRIPTION="X keyboard configuration database"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig/ https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
@@ -26,8 +26,8 @@ BDEPEND="
dev-lang/perl
dev-libs/libxslt
sys-devel/gettext
+ ${PYTHON_DEPS}
test? (
- ${PYTHON_DEPS}
x11-apps/xkbcomp
x11-libs/libxkbcommon
$(python_gen_any_dep '
@@ -47,7 +47,7 @@ python_check_deps() {
}
pkg_setup() {
- use test && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
}
src_prepare() {