summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/libvirt-python/Manifest2
-rw-r--r--dev-python/libvirt-python/libvirt-python-9.3.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 68406eba26a6..409b72f934ca 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -6,3 +6,5 @@ DIST libvirt-python-8.9.0.tar.gz 240769 BLAKE2B 992f02fe584f33ea5bd91a28338e281d
DIST libvirt-python-8.9.0.tar.gz.asc 833 BLAKE2B 690613f7f558155db56a5194042bdf49e004143b2066bcaccb48fc9082364a88b5f8d4112623095838a116817a55e34e8ca29e01221299efc396fb1501a060ae SHA512 a490284745c948d87f0239b70257b5cd66ae2515a4f3f33c05a2b3e1ccc28e2769c8c61d45e4f855b595a6d82b6d73e50bcd00a8bbfc7cb7fbe1a4969e48e17b
DIST libvirt-python-9.2.0.tar.gz 243411 BLAKE2B 4478060de12fe78dc60505cbfdc9a38d398ea3860e9a1a146379695f6ed7ec21d8840b54e6a716b1177e422a934ec5dfd86365208147515f70bc02c605c32b8c SHA512 24abeb7ec27135c30cdf751476b091b89b3aa2e448f6fe57d29064e1465a49944b2c0bb19cb01ce4d728036c9387bb244594816a9853a00b1d43d89dd7f94cd5
DIST libvirt-python-9.2.0.tar.gz.asc 833 BLAKE2B 8f09ba2399fa083d41c979354dd72ca0c44047f46c6117b08cf823d8fc7ba5a2bfa031e51855238865dc08eb77846362d200d362e8675049f32b635e40bb25cc SHA512 4cb0bffaaa95e93cff1dd2f35f0219bc97567e21e04778b6f5bd0b33aa3523cea43f5fd7d95da73ba82f695b2cab8c771a5adbd9511e8a6deeb13e7e80fe7aa2
+DIST libvirt-python-9.3.0.tar.gz 244181 BLAKE2B 1f472233ea336bf7196f83c41606817c6422b08ba76bb07a39510018498cc378a3e31626155e9953881ac4718ca642df6878e9a2b6bfe74116052819fabf63c6 SHA512 5fe04eb6fbccb20f90637d5bb74887b0676743761838c91f6c7f08f8aff39ea8e1d8cdc50c4c244918c2100efb00c6bb380ac44b4d403a08863c8c99ecdbe937
+DIST libvirt-python-9.3.0.tar.gz.asc 833 BLAKE2B bb3f47ce3dea2fca251a956c170f98406485f3b738e068d6b3dab59c5f440aba7127683f484278866d5b39f53cd18a5dbb9697e701515c6d93141b3e7ecae18b SHA512 0123bc657ec2680ea998e70c62f2dba0f5960239faa43158e4897e4e3e287a0fdb29daa409bf98514b271477410308c959a0ab1e4e90fa82f409cd4f858201fe
diff --git a/dev-python/libvirt-python/libvirt-python-9.3.0.ebuild b/dev-python/libvirt-python/libvirt-python-9.3.0.ebuild
new file mode 100644
index 000000000000..25f4ff942c9e
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-9.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+MY_P="${P/_rc/-rc}"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libvirt.org.asc
+inherit distutils-r1 verify-sig
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-python.git"
+ RDEPEND="app-emulation/libvirt:="
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz
+ verify-sig? ( https://libvirt.org/sources/python/${MY_P}.tar.gz.asc )"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+ verify-sig? ( sec-keys/openpgp-keys-libvirt )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}