summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/http-4000.3.14.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-haskell/http/http-4000.3.14.ebuild b/dev-haskell/http/http-4000.3.14.ebuild
index 3d0ac020959f..c2e843e563e2 100644
--- a/dev-haskell/http/http-4000.3.14.ebuild
+++ b/dev-haskell/http/http-4000.3.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,8 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="conduit10 +network-uri"
+RESTRICT=test # requires network
+
RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
>=dev-lang/ghc-7.4.1:=
@@ -40,6 +42,13 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.3.0.0 && < 4.14' 'base >= 4.3.0.0'
+}
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag conduit10 conduit10) \