summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cleo/Manifest1
-rw-r--r--dev-python/cleo/cleo-2.2.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cleo/Manifest b/dev-python/cleo/Manifest
index 96e21f71bf3f..af13cbc69e2f 100644
--- a/dev-python/cleo/Manifest
+++ b/dev-python/cleo/Manifest
@@ -1 +1,2 @@
DIST cleo-2.1.0.gh.tar.gz 165795 BLAKE2B 7c9d0cc869d1e185c2c5a092a8aa1d1b3cce5fc25246939c0ff94920ac7070000b110be9f6cd9d1f827ed951ff22b9ad62e3c17a941022967b7599e456cda837 SHA512 e73a4c02470052f0f602fae8b5bf7073f3342d0816074398b19f0fb25caddda51b6d2fcb9ef57026638d0dc8861a2b5142d87551b105cefa5e54426e4aa1225c
+DIST cleo-2.2.1.gh.tar.gz 162526 BLAKE2B 2f5da066672ecf7067801cd6287cd81055be893001a00067ada150c76363dde1ad3dc715d030963a15cee56080a15d1843d34499a92a55a4d4a3dfe340239ce5 SHA512 905411ca3f4769b12857df807e19f42f88f2aade3dd9b7f38dc3e61efce926479a6afcfc4cfff622ec98122d35871eef47e9146a61a159d4cf083e9eceb3b4ed
diff --git a/dev-python/cleo/cleo-2.2.1.ebuild b/dev-python/cleo/cleo-2.2.1.ebuild
new file mode 100644
index 000000000000..4bc240fc5885
--- /dev/null
+++ b/dev-python/cleo/cleo-2.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool for building testable command-line interfaces"
+HOMEPAGE="
+ https://github.com/python-poetry/cleo/
+ https://pypi.org/project/cleo/
+"
+SRC_URI="
+ https://github.com/python-poetry/cleo/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin rapidfuzz
+ sed -i -e '/rapidfuzz/s:\^:>=:' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ tests/ui/test_exception_trace.py::test_render_debug_better_error_message_recursion_error
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock
+ epytest
+}