summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/akonadi-contacts')
-rw-r--r--kde-apps/akonadi-contacts/Manifest1
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-16.08.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/Manifest b/kde-apps/akonadi-contacts/Manifest
index 8b36cbca378b..86a24d2b8897 100644
--- a/kde-apps/akonadi-contacts/Manifest
+++ b/kde-apps/akonadi-contacts/Manifest
@@ -1 +1,2 @@
DIST akonadi-contacts-16.08.2.tar.xz 149292 SHA256 f480c5c1a09317a64ac5cdf7c74fc87ac5f9af7ba2f211fcfee89c48b0976c34 SHA512 a1666da3b41f9827305671a6771f98a1db14a93f2e8b06ea8cb14636dd2abd3708fed0e1f008a7b7491f7cff58c88527209163657add87a59f131e06569a0e2d WHIRLPOOL 2b4ca65178ab5f213492b4d5fff3aac8ed2699ad64184b10c820da5a53982ee6ea026355e30ccefdb8c82e544f2e559178657385cbbd3e8d474ed153f7ac4e64
+DIST akonadi-contacts-16.08.3.tar.xz 149272 SHA256 ad2e6f6169f2700cb8c252d7780eefbbc5bf57ed8dac5f1c868a9f78fac48d89 SHA512 b306b378bbef50c63c7e91b5a766a3448722cb0c6bd818f3684d802a6404dfed1014a3707271f47ef10aad8387574105515c115d71eb090ac83f559ad9561182 WHIRLPOOL dcd444616e13d2426eb2a5633445a1d515b97577cd7fd53fc16e13669f78e3e4c80a62c13d02cca4bc8c7cb422ecf5668bb41f9b190ca750d78ed0ed717402d7
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-16.08.3.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-16.08.3.ebuild
new file mode 100644
index 000000000000..41aa18e4fc94
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-16.08.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for akonadi contact integration"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+IUSE="prison"
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-libs/grantlee-5.1.0:5
+ prison? ( media-libs/prison:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package prison KF5Prison)
+ )
+
+ kde5_src_configure
+}