summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/aview')
-rw-r--r--media-gfx/aview/Manifest1
-rw-r--r--media-gfx/aview/aview-1.3.0_rc1-r1.ebuild38
-rw-r--r--media-gfx/aview/aview-1.3.0_rc1-r3.ebuild43
-rw-r--r--media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch76
-rw-r--r--media-gfx/aview/files/aview-1.3.0_rc1-filename-spaces.patch53
-rw-r--r--media-gfx/aview/files/aview-1.3.0_rc1-includes.patch11
-rw-r--r--media-gfx/aview/files/aview-1.3.0_rc1-tmp_creation.patch46
-rw-r--r--media-gfx/aview/metadata.xml10
8 files changed, 278 insertions, 0 deletions
diff --git a/media-gfx/aview/Manifest b/media-gfx/aview/Manifest
new file mode 100644
index 000000000000..ce00fc6250b8
--- /dev/null
+++ b/media-gfx/aview/Manifest
@@ -0,0 +1 @@
+DIST aview-1.3.0rc1.tar.gz 54317 SHA256 42d61c4194e8b9b69a881fdde698c83cb27d7eda59e08b300e73aaa34474ec99 SHA512 941f2a92aaf3852b403daf688cda4ca2eb82ec32ee6566cd2aef3d121f259f1bb0214f872c4d5020c658bd81adba0577313acc5972d2f44b295f21905e107144 WHIRLPOOL eae555567be4943f16542b75e6f68b7c7548d8028f16cfe12f46648ed27bd8cbd87189d1925e7fe16a7c86247f121aca82fa24f9e901844ec6e9f39c7bcff74d
diff --git a/media-gfx/aview/aview-1.3.0_rc1-r1.ebuild b/media-gfx/aview/aview-1.3.0_rc1-r1.ebuild
new file mode 100644
index 000000000000..e3e3ff7c071f
--- /dev/null
+++ b/media-gfx/aview/aview-1.3.0_rc1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit base
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P/rc*/}
+DESCRIPTION="An ASCII Image Viewer"
+SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
+HOMEPAGE="http://aa-project.sourceforge.net/aview/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=media-libs/aalib-1.4_rc4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-filename-spaces.patch
+ "${FILESDIR}"/${P}-tmp_creation.patch
+ "${FILESDIR}"/${P}-includes.patch
+)
+
+src_compile() {
+ econf || die
+ make aview || die
+}
+
+src_install() {
+ into /usr
+ dobin aview asciiview
+
+ doman *.1
+ dodoc ANNOUNCE ChangeLog README TODO
+}
diff --git a/media-gfx/aview/aview-1.3.0_rc1-r3.ebuild b/media-gfx/aview/aview-1.3.0_rc1-r3.ebuild
new file mode 100644
index 000000000000..ee28b891243e
--- /dev/null
+++ b/media-gfx/aview/aview-1.3.0_rc1-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P/rc*/}
+DESCRIPTION="An ASCII Image Viewer"
+SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
+HOMEPAGE="http://aa-project.sourceforge.net/aview/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE=""
+
+DEPEND=">=media-libs/aalib-1.4_rc4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-asciiview.patch
+ "${FILESDIR}"/${P}-includes.patch
+)
+
+src_prepare() {
+ base_src_prepare
+
+ sed -i -e 's:#include <malloc.h>:#include <stdlib.h>:g' "${S}"/*.c || die
+}
+
+src_compile() {
+ make aview
+}
+
+src_install() {
+ dobin aview asciiview
+
+ doman *.1
+ dodoc ANNOUNCE ChangeLog README TODO
+}
diff --git a/media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch b/media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch
new file mode 100644
index 000000000000..6d71bbb967b1
--- /dev/null
+++ b/media-gfx/aview/files/aview-1.3.0_rc1-asciiview.patch
@@ -0,0 +1,76 @@
+Support spaces in filenames (bug #39207) based on a patch from
+kyberneticist AT yahoo DOT com with additional fixes to address bug
+#293654 by Kevin McCarthy <signals@gentoo.org>
+
+Fix insecure temporary file permissions (bug #235808) based on a patch from
+Robert Buchholz <rbu@gentoo.org>
+
+Fix ignored interactive keyboard commands when aview is called from the
+asciiview script (bug #293654) by Kevin McCarthy <signals@gentoo.org>
+
+Rollup patch created by Kevin McCarthy <signals@gentoo.org>
+
+--- asciiview
++++ asciiview
+@@ -3,13 +3,13 @@
+ clear()
+ {
+ kill $! 2>/dev/null
+- rm -f /tmp/aview$$.pgm 2>/dev/null
++ rm -rf $tmpdir 2>/dev/null
+ }
+ myconvert()
+ {
+- if anytopnm $1 >/tmp/aview$$.pgm 2>/dev/null ; then
++ if anytopnm "$1" >"$2" 2>/dev/null ; then
+ exit
+- elif convert -colorspace gray $1 pgm:- 2>/dev/null ; then
++ elif convert -colorspace gray "$1" pgm:- 2>/dev/null ; then
+ exit
+ fi
+ echo "Failed to convert file format to PNM by both convert and anytopnm" >&2
+@@ -44,27 +44,34 @@
+ options="$options $1"
+ shift
+ ;;
+- *)
+- filenames="$filenames $1"
++ *)
++ if [ "$filenames" = "" ]
++ then
++ filenames=$1 #avoid leading null
++ else
++ filenames=$(echo -e "$filenames\n$1")
++ fi
+ shift
+ ;;
+ esac
+ done
+ trap clear 0
+-mkfifo /tmp/aview$$.pgm
+-outfile=/tmp/aview$$.pgm
+-for name in $filenames ; do
+-if test -r $name ; then
+-case $name in
++tmpdir=`mktemp -t -d`
++outfile=$tmpdir/aview.pgm
++mkfifo $outfile
++exec 3<&0
++echo "$filenames" | while read name; do
++if test -r "$name" ; then
++case "$name" in
+ *.fli | *.lfc | *.flic )
+ PATH="$PATH:."
+- aaflip $options $name
++ aaflip $options "$name"
+ ;;
+ *)
+- myconvert $name >/tmp/aview$$.pgm &
++ myconvert "$name" "$outfile" >"$outfile" &
+ pid=$!
+ PATH="$PATH:."
+- aview $options /tmp/aview$$.pgm
++ aview $options $outfile <&3
+ kill $pid 2>/dev/null
+ esac
+ else
diff --git a/media-gfx/aview/files/aview-1.3.0_rc1-filename-spaces.patch b/media-gfx/aview/files/aview-1.3.0_rc1-filename-spaces.patch
new file mode 100644
index 000000000000..e42ed0d5c583
--- /dev/null
+++ b/media-gfx/aview/files/aview-1.3.0_rc1-filename-spaces.patch
@@ -0,0 +1,53 @@
+diff -ur aview-1.3.0-orig/asciiview aview-1.3.0/asciiview
+--- aview-1.3.0-orig/asciiview 2005-08-15 21:20:16.000000000 -0400
++++ aview-1.3.0/asciiview 2005-08-15 21:20:19.000000000 -0400
+@@ -7,9 +7,9 @@
+ }
+ myconvert()
+ {
+- if anytopnm $1 >/tmp/aview$$.pgm 2>/dev/null ; then
++ if anytopnm "$1" >/tmp/aview$$.pgm 2>/dev/null ; then
+ exit
+- elif convert -colorspace gray $1 pgm:- 2>/dev/null ; then
++ elif convert -colorspace gray "$1" pgm:- 2>/dev/null ; then
+ exit
+ fi
+ echo "Failed to convert file format to PNM by both convert and anytopnm" >&2
+@@ -44,8 +44,13 @@
+ options="$options $1"
+ shift
+ ;;
+- *)
+- filenames="$filenames $1"
++ *)
++ if [ "$filenames" = "" ]
++ then
++ filenames=$1 #avoid leading null
++ else
++ filenames=$(echo -e "$filenames\000$1")
++ fi
+ shift
+ ;;
+ esac
+@@ -53,15 +58,16 @@
+ trap clear 0
+ mkfifo /tmp/aview$$.pgm
+ outfile=/tmp/aview$$.pgm
+-for name in $filenames ; do
+-if test -r $name ; then
+-case $name in
++IFS=$(echo -e "\000")
++echo $filenames | while read name; do
++if test -r "$name" ; then
++case "$name" in
+ *.fli | *.lfc | *.flic )
+ PATH="$PATH:."
+- aaflip $options $name
++ aaflip $options "$name"
+ ;;
+ *)
+- myconvert $name >/tmp/aview$$.pgm &
++ myconvert "$name" >/tmp/aview$$.pgm &
+ pid=$!
+ PATH="$PATH:."
+ aview $options /tmp/aview$$.pgm
diff --git a/media-gfx/aview/files/aview-1.3.0_rc1-includes.patch b/media-gfx/aview/files/aview-1.3.0_rc1-includes.patch
new file mode 100644
index 000000000000..3e5006b4c549
--- /dev/null
+++ b/media-gfx/aview/files/aview-1.3.0_rc1-includes.patch
@@ -0,0 +1,11 @@
+Index: aview-1.3.0/main.c
+===================================================================
+--- aview-1.3.0.orig/main.c
++++ aview-1.3.0/main.c
+@@ -1,4 +1,6 @@
+ #include <aalib.h>
++#include <string.h>
++#include <stdlib.h>
+ #include "image.h"
+ #include "ui.h"
+ #include "config.h"
diff --git a/media-gfx/aview/files/aview-1.3.0_rc1-tmp_creation.patch b/media-gfx/aview/files/aview-1.3.0_rc1-tmp_creation.patch
new file mode 100644
index 000000000000..f792e8bfebbb
--- /dev/null
+++ b/media-gfx/aview/files/aview-1.3.0_rc1-tmp_creation.patch
@@ -0,0 +1,46 @@
+Fix insecure temporary file creation, see:
+https://bugs.gentoo.org/show_bug.cgi?id=235808
+
+Index: aview-1.3.0/asciiview
+===================================================================
+--- aview-1.3.0.orig/asciiview
++++ aview-1.3.0/asciiview
+@@ -3,11 +3,11 @@
+ clear()
+ {
+ kill $! 2>/dev/null
+- rm -f /tmp/aview$$.pgm 2>/dev/null
++ rm -rf $tmpdir 2>/dev/null
+ }
+ myconvert()
+ {
+- if anytopnm "$1" >/tmp/aview$$.pgm 2>/dev/null ; then
++ if anytopnm "$1" >"$2" 2>/dev/null ; then
+ exit
+ elif convert -colorspace gray "$1" pgm:- 2>/dev/null ; then
+ exit
+@@ -56,8 +56,9 @@ while [ "$1" != "" ]; do
+ esac
+ done
+ trap clear 0
+-mkfifo /tmp/aview$$.pgm
+-outfile=/tmp/aview$$.pgm
++tmpdir=`mktemp -t -d`
++outfile=$tmpdir/aview.pgm
++mkfifo $outfile
+ IFS=$(echo -e "\000")
+ echo $filenames | while read name; do
+ if test -r "$name" ; then
+@@ -67,10 +68,10 @@ case "$name" in
+ aaflip $options "$name"
+ ;;
+ *)
+- myconvert "$name" >/tmp/aview$$.pgm &
++ myconvert "$name" "$outfile" >"$outfile" &
+ pid=$!
+ PATH="$PATH:."
+- aview $options /tmp/aview$$.pgm
++ aview $options $outfile
+ kill $pid 2>/dev/null
+ esac
+ else
diff --git a/media-gfx/aview/metadata.xml b/media-gfx/aview/metadata.xml
new file mode 100644
index 000000000000..98a05a1b7158
--- /dev/null
+++ b/media-gfx/aview/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">aa-project</remote-id>
+ </upstream>
+</pkgmetadata>