summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/csound/csound-6.17.0-r1.ebuild7
-rw-r--r--media-sound/csound/csound-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/media-sound/csound/csound-6.17.0-r1.ebuild b/media-sound/csound/csound-6.17.0-r1.ebuild
index 80c295ef8405..4d3489c2ab05 100644
--- a/media-sound/csound/csound-6.17.0-r1.ebuild
+++ b/media-sound/csound/csound-6.17.0-r1.ebuild
@@ -10,7 +10,7 @@ EAPI=8
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake lua-single python-single-r1
+inherit cmake flag-o-matic lua-single python-single-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
@@ -117,6 +117,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/860492
+ # https://github.com/csound/csound/issues/1919
+ filter-lto
+
local mycmakeargs=(
-DBUILD_BELA=OFF
-DBUILD_CSBEATS=$(usex beats)
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index 80c295ef8405..4d3489c2ab05 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -10,7 +10,7 @@ EAPI=8
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake lua-single python-single-r1
+inherit cmake flag-o-matic lua-single python-single-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
@@ -117,6 +117,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/860492
+ # https://github.com/csound/csound/issues/1919
+ filter-lto
+
local mycmakeargs=(
-DBUILD_BELA=OFF
-DBUILD_CSBEATS=$(usex beats)