summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gnuradio/gnuradio-3.8.1.0.ebuild14
-rw-r--r--net-wireless/gnuradio/gnuradio-9999.ebuild11
2 files changed, 24 insertions, 1 deletions
diff --git a/net-wireless/gnuradio/gnuradio-3.8.1.0.ebuild b/net-wireless/gnuradio/gnuradio-3.8.1.0.ebuild
index 876a00b18cf1..1ba2694abe76 100644
--- a/net-wireless/gnuradio/gnuradio-3.8.1.0.ebuild
+++ b/net-wireless/gnuradio/gnuradio-3.8.1.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
CMAKE_BUILD_TYPE="None"
-inherit cmake-utils python-single-r1 virtualx xdg-utils
+inherit cmake-utils python-single-r1 virtualx xdg-utils desktop
DESCRIPTION="Toolkit that provides signal processing blocks to implement software radios"
HOMEPAGE="https://www.gnuradio.org/"
@@ -130,6 +130,7 @@ src_configure() {
mycmakeargs=(
-DENABLE_DEFAULT=OFF
-DENABLE_VOLK=OFF
+ -DENABLE_INTERNAL_VOLK=OFF
-DENABLE_GNURADIO_RUNTIME=ON
-DENABLE_PYTHON=ON
-DENABLE_GR_BLOCKS=ON
@@ -183,6 +184,17 @@ src_install() {
rm -rf "${ED}"/usr/share/${PN}/grc/freedesktop || die
rm -f "${ED}"/usr/libexec/${PN}/grc_setup_freedesktop || die
+ # Install icons, menu items and mime-types for GRC
+ if use grc ; then
+ local fd_path="${S}/grc/scripts/freedesktop"
+ insinto /usr/share/mime/packages
+ doins "${fd_path}/${PN}-grc.xml"
+
+ domenu "${fd_path}/"*.desktop
+ doicon "${fd_path}/"*.png
+ fi
+
+ python_fix_shebang "${ED}"
# Remove incorrectly byte-compiled Python files and replace
find "${ED}"/usr/lib -name "*.py[co]" -exec rm {} \; || die
python_optimize
diff --git a/net-wireless/gnuradio/gnuradio-9999.ebuild b/net-wireless/gnuradio/gnuradio-9999.ebuild
index 445acb55d959..c3f9aab150ea 100644
--- a/net-wireless/gnuradio/gnuradio-9999.ebuild
+++ b/net-wireless/gnuradio/gnuradio-9999.ebuild
@@ -184,6 +184,17 @@ src_install() {
rm -rf "${ED}"/usr/share/${PN}/grc/freedesktop || die
rm -f "${ED}"/usr/libexec/${PN}/grc_setup_freedesktop || die
+ # Install icons, menu items and mime-types for GRC
+ if use grc ; then
+ local fd_path="${S}/grc/scripts/freedesktop"
+ insinto /usr/share/mime/packages
+ doins "${fd_path}/${PN}-grc.xml"
+
+ domenu "${fd_path}/"*.desktop
+ doicon "${fd_path}/"*.png
+ fi
+
+ python_fix_shebang "${ED}"
# Remove incorrectly byte-compiled Python files and replace
find "${ED}"/usr/lib -name "*.py[co]" -exec rm {} \; || die
python_optimize