summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/lshw/lshw-02.17b-r2.ebuild')
-rw-r--r--sys-apps/lshw/lshw-02.17b-r2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-apps/lshw/lshw-02.17b-r2.ebuild b/sys-apps/lshw/lshw-02.17b-r2.ebuild
index ffd8414595ee..74fc33cfafa8 100644
--- a/sys-apps/lshw/lshw-02.17b-r2.ebuild
+++ b/sys-apps/lshw/lshw-02.17b-r2.ebuild
@@ -43,10 +43,13 @@ src_prepare() {
sed -i \
-e "/^LANGUAGES =/ s/=.*/= $(l10n_get_locales)/" \
src/po/Makefile || die
+ sed -i \
+ -e 's:\<pkg-config\>:${PKG_CONFIG}:' \
+ src/Makefile src/gui/Makefile || die
}
src_compile() {
- tc-export CC CXX AR
+ tc-export CC CXX AR PKG_CONFIG
use static && append-ldflags -static
# Need two sep make statements to avoid parallel build issues. #588174