From 80bc298ab1ddbef90ada31882e3353324c42fb03 Mon Sep 17 00:00:00 2001
From: Jeroen Roovers <jer@gentoo.org>
Date: Sat, 7 Dec 2019 13:49:36 +0100
Subject: net-analyzer/net-snmp: Call python_optimize in src_install()

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
---
 net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild | 206 --------------------------
 net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild | 208 +++++++++++++++++++++++++++
 2 files changed, 208 insertions(+), 206 deletions(-)
 delete mode 100644 net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild
 create mode 100644 net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild

diff --git a/net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild b/net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild
deleted file mode 100644
index a7359956604a..000000000000
--- a/net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild
+++ /dev/null
@@ -1,206 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_SINGLE_IMPL=yesplz
-DISTUTILS_OPTIONAL=yesplz
-WANT_AUTOMAKE=none
-PATCHSET=3
-GENTOO_DEPEND_ON_PERL=no
-
-inherit autotools distutils-r1 eutils perl-module systemd
-
-DESCRIPTION="Software for generating and retrieving SNMP data"
-HOMEPAGE="http://www.net-snmp.org/"
-SRC_URI="
-	mirror://sourceforge/project/${PN}/${PN}/${PV/_p*/}/${P/_p*/}.tar.gz
-	https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-3.tar.xz
-"
-
-S=${WORKDIR}/${P/_/.}
-
-# GPL-2 for the init scripts
-LICENSE="HPND BSD GPL-2"
-SLOT="0/35"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="
-	X bzip2 doc elf kmem ipv6 libressl lm-sensors mfd-rewrites minimal mysql
-	netlink pcap pci perl python rpm selinux smux ssl tcpd ucd-compat zlib
-"
-
-COMMON_DEPEND="
-	bzip2? ( app-arch/bzip2 )
-	elf? ( dev-libs/elfutils )
-	lm-sensors? ( sys-apps/lm-sensors )
-	mysql? ( dev-db/mysql-connector-c:0= )
-	netlink? ( dev-libs/libnl:3 )
-	pcap? ( net-libs/libpcap )
-	pci? ( sys-apps/pciutils )
-	perl? ( dev-lang/perl:= )
-	python? (
-		dev-python/setuptools[${PYTHON_USEDEP}]
-		${PYTHON_DEPS}
-	)
-	rpm? (
-		app-arch/rpm
-		dev-libs/popt
-	)
-	ssl? (
-		!libressl? ( >=dev-libs/openssl-0.9.6d:0= )
-		libressl? ( dev-libs/libressl:= )
-	)
-	tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
-	zlib? ( >=sys-libs/zlib-1.1.4 )
-"
-DEPEND="
-	${COMMON_DEPEND}
-	doc? ( app-doc/doxygen )
-"
-RDEPEND="
-	${COMMON_DEPEND}
-	perl? (
-		X? ( dev-perl/Tk )
-		!minimal? ( dev-perl/TermReadKey )
-	)
-	selinux? ( sec-policy/selinux-snmp )
-"
-
-REQUIRED_USE="
-	python? ( ${PYTHON_REQUIRED_USE} )
-	rpm? ( bzip2 zlib )
-"
-S=${WORKDIR}/${P/_p*/}
-
-RESTRICT=test
-
-pkg_setup() {
-	use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
-	# snmpconf generates config files with proper selinux context
-	use selinux && eapply "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
-
-	eapply "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
-	eapply "${FILESDIR}"/${PN}-5.8-do-not-conflate-LDFLAGS-and-LIBS.patch
-	eapply "${FILESDIR}"/${PN}-5.8-my_bool.patch
-	eapply "${FILESDIR}"/${PN}-5.8-pcap.patch
-	eapply "${FILESDIR}"/${PN}-5.8-tinfo.patch
-
-	mv "${WORKDIR}"/patches/0002-Respect-DESTDIR-for-pythoninstall.patch{,.disabled} || die
-	mv "${WORKDIR}"/patches/0004-Don-t-report-CFLAGS-and-LDFLAGS-in-net-snmp-config.patch{,.disabled} || die
-	eapply "${WORKDIR}"/patches/*.patch
-
-	eapply_user
-
-	eautoconf
-}
-
-src_configure() {
-	# keep this in the same line, configure.ac arguments are passed down to config.h
-	local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail etherlike-mib/dot3StatsTable"
-	use lm-sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
-	use smux && mibs="${mibs} smux"
-
-	# Assume /etc/mtab is not present with a recent baselayout/openrc (bug #565136)
-	use kernel_linux && export ac_cv_ETC_MNTTAB=/etc/mtab
-
-	econf \
-		$(use_enable !ssl internal-md5) \
-		$(use_enable ipv6) \
-		$(use_enable mfd-rewrites) \
-		$(use_enable perl embedded-perl) \
-		$(use_enable ucd-compat ucd-snmp-compatibility) \
-		$(use_with bzip2) \
-		$(use_with elf) \
-		$(use_with kmem kmem-usage) \
-		$(use_with mysql) \
-		$(use_with netlink nl) \
-		$(use_with pcap) \
-		$(use_with pci) \
-		$(use_with perl perl-modules INSTALLDIRS=vendor) \
-		$(use_with python python-modules) \
-		$(use_with rpm) \
-		$(use_with ssl openssl) \
-		$(use_with tcpd libwrap) \
-		$(use_with zlib) \
-		--enable-shared --disable-static \
-		--with-default-snmp-version="3" \
-		--with-install-prefix="${D}" \
-		--with-ldflags="${LDFLAGS}" \
-		--with-logfile="/var/log/net-snmpd.log" \
-		--with-mib-modules="${mibs}" \
-		--with-persistent-directory="/var/lib/net-snmp" \
-		--with-sys-contact="root@Unknown" \
-		--with-sys-location="Unknown"
-}
-
-src_compile() {
-	for target in snmplib agent sedscript all; do
-		emake OTHERLDFLAGS="${LDFLAGS}" ${target}
-	done
-
-	use doc && emake docsdox
-}
-
-src_install () {
-	# bug #317965
-	emake -j1 DESTDIR="${D}" install
-
-	if use perl ; then
-		perl_delete_localpod
-		if ! use X; then
-			rm "${D}"/usr/bin/tkmib || die
-		fi
-	else
-		rm -f \
-			"${D}"/usr/bin/fixproc \
-			"${D}"/usr/bin/ipf-mod.pl \
-			"${D}"/usr/bin/mib2c \
-			"${D}"/usr/bin/net-snmp-cert \
-			"${D}"/usr/bin/snmp-bridge-mib \
-			"${D}"/usr/bin/snmpcheck \
-			"${D}"/usr/bin/snmpconf \
-			"${D}"/usr/bin/tkmib \
-			"${D}"/usr/bin/traptoemail \
-			"${D}"/usr/share/snmp/mib2c.perl.conf \
-			"${D}"/usr/share/snmp/snmp_perl_trapd.pl \
-			|| die
-	fi
-
-	dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO
-	newdoc EXAMPLE.conf.def EXAMPLE.conf
-
-	if use doc; then
-		docinto html
-		dodoc -r docs/html/*
-	fi
-
-	keepdir /var/lib/net-snmp
-
-	newinitd "${FILESDIR}"/snmpd.init.2 snmpd
-	newconfd "${FILESDIR}"/snmpd.conf snmpd
-
-	newinitd "${FILESDIR}"/snmptrapd.init.2 snmptrapd
-	newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd
-
-	systemd_dounit "${FILESDIR}"/snmpd.service
-	systemd_dounit "${FILESDIR}"/snmptrapd.service
-
-	insinto /etc/snmp
-	newins "${S}"/EXAMPLE.conf snmpd.conf.example
-
-	# Remove everything not required for an agent.
-	# Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
-	if use minimal; then
-		rm -rf \
-			"${D}"/**/*.pl \
-			"${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,check,conf},fixproc,traptoemail} \
-			"${D}"/usr/share/snmp/*.conf \
-			"${D}"/usr/share/snmp/snmpconf-data \
-			|| die
-	fi
-
-	prune_libtool_files
-}
diff --git a/net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild b/net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild
new file mode 100644
index 000000000000..2b3f66b5294d
--- /dev/null
+++ b/net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=yesplz
+DISTUTILS_OPTIONAL=yesplz
+WANT_AUTOMAKE=none
+PATCHSET=3
+GENTOO_DEPEND_ON_PERL=no
+
+inherit autotools distutils-r1 eutils perl-module systemd
+
+DESCRIPTION="Software for generating and retrieving SNMP data"
+HOMEPAGE="http://www.net-snmp.org/"
+SRC_URI="
+	mirror://sourceforge/project/${PN}/${PN}/${PV/_p*/}/${P/_p*/}.tar.gz
+	https://dev.gentoo.org/~jer/${PN}-5.7.3-patches-3.tar.xz
+"
+
+S=${WORKDIR}/${P/_/.}
+
+# GPL-2 for the init scripts
+LICENSE="HPND BSD GPL-2"
+SLOT="0/35"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="
+	X bzip2 doc elf kmem ipv6 libressl lm-sensors mfd-rewrites minimal mysql
+	netlink pcap pci perl python rpm selinux smux ssl tcpd ucd-compat zlib
+"
+
+COMMON_DEPEND="
+	bzip2? ( app-arch/bzip2 )
+	elf? ( dev-libs/elfutils )
+	lm-sensors? ( sys-apps/lm-sensors )
+	mysql? ( dev-db/mysql-connector-c:0= )
+	netlink? ( dev-libs/libnl:3 )
+	pcap? ( net-libs/libpcap )
+	pci? ( sys-apps/pciutils )
+	perl? ( dev-lang/perl:= )
+	python? (
+		dev-python/setuptools[${PYTHON_USEDEP}]
+		${PYTHON_DEPS}
+	)
+	rpm? (
+		app-arch/rpm
+		dev-libs/popt
+	)
+	ssl? (
+		!libressl? ( >=dev-libs/openssl-0.9.6d:0= )
+		libressl? ( dev-libs/libressl:= )
+	)
+	tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+	zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+	${COMMON_DEPEND}
+	doc? ( app-doc/doxygen )
+"
+RDEPEND="
+	${COMMON_DEPEND}
+	perl? (
+		X? ( dev-perl/Tk )
+		!minimal? ( dev-perl/TermReadKey )
+	)
+	selinux? ( sec-policy/selinux-snmp )
+"
+
+REQUIRED_USE="
+	python? ( ${PYTHON_REQUIRED_USE} )
+	rpm? ( bzip2 zlib )
+"
+S=${WORKDIR}/${P/_p*/}
+
+RESTRICT=test
+
+pkg_setup() {
+	use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+	# snmpconf generates config files with proper selinux context
+	use selinux && eapply "${FILESDIR}"/${PN}-5.1.2-snmpconf-selinux.patch
+
+	eapply "${FILESDIR}"/${PN}-5.7.3-include-limits.patch
+	eapply "${FILESDIR}"/${PN}-5.8-do-not-conflate-LDFLAGS-and-LIBS.patch
+	eapply "${FILESDIR}"/${PN}-5.8-my_bool.patch
+	eapply "${FILESDIR}"/${PN}-5.8-pcap.patch
+	eapply "${FILESDIR}"/${PN}-5.8-tinfo.patch
+
+	mv "${WORKDIR}"/patches/0002-Respect-DESTDIR-for-pythoninstall.patch{,.disabled} || die
+	mv "${WORKDIR}"/patches/0004-Don-t-report-CFLAGS-and-LDFLAGS-in-net-snmp-config.patch{,.disabled} || die
+	eapply "${WORKDIR}"/patches/*.patch
+
+	eapply_user
+
+	eautoconf
+}
+
+src_configure() {
+	# keep this in the same line, configure.ac arguments are passed down to config.h
+	local mibs="host ucd-snmp/dlmod ucd-snmp/diskio ucd-snmp/extensible mibII/mta_sendmail etherlike-mib/dot3StatsTable"
+	use lm-sensors && mibs="${mibs} ucd-snmp/lmsensorsMib"
+	use smux && mibs="${mibs} smux"
+
+	# Assume /etc/mtab is not present with a recent baselayout/openrc (bug #565136)
+	use kernel_linux && export ac_cv_ETC_MNTTAB=/etc/mtab
+
+	econf \
+		$(use_enable !ssl internal-md5) \
+		$(use_enable ipv6) \
+		$(use_enable mfd-rewrites) \
+		$(use_enable perl embedded-perl) \
+		$(use_enable ucd-compat ucd-snmp-compatibility) \
+		$(use_with bzip2) \
+		$(use_with elf) \
+		$(use_with kmem kmem-usage) \
+		$(use_with mysql) \
+		$(use_with netlink nl) \
+		$(use_with pcap) \
+		$(use_with pci) \
+		$(use_with perl perl-modules INSTALLDIRS=vendor) \
+		$(use_with python python-modules) \
+		$(use_with rpm) \
+		$(use_with ssl openssl) \
+		$(use_with tcpd libwrap) \
+		$(use_with zlib) \
+		--enable-shared --disable-static \
+		--with-default-snmp-version="3" \
+		--with-install-prefix="${D}" \
+		--with-ldflags="${LDFLAGS}" \
+		--with-logfile="/var/log/net-snmpd.log" \
+		--with-mib-modules="${mibs}" \
+		--with-persistent-directory="/var/lib/net-snmp" \
+		--with-sys-contact="root@Unknown" \
+		--with-sys-location="Unknown"
+}
+
+src_compile() {
+	for target in snmplib agent sedscript all; do
+		emake OTHERLDFLAGS="${LDFLAGS}" ${target}
+	done
+
+	use doc && emake docsdox
+}
+
+src_install () {
+	# bug #317965
+	emake -j1 DESTDIR="${D}" install
+
+	use python && python_optimize
+
+	if use perl ; then
+		perl_delete_localpod
+		if ! use X; then
+			rm "${D}"/usr/bin/tkmib || die
+		fi
+	else
+		rm -f \
+			"${D}"/usr/bin/fixproc \
+			"${D}"/usr/bin/ipf-mod.pl \
+			"${D}"/usr/bin/mib2c \
+			"${D}"/usr/bin/net-snmp-cert \
+			"${D}"/usr/bin/snmp-bridge-mib \
+			"${D}"/usr/bin/snmpcheck \
+			"${D}"/usr/bin/snmpconf \
+			"${D}"/usr/bin/tkmib \
+			"${D}"/usr/bin/traptoemail \
+			"${D}"/usr/share/snmp/mib2c.perl.conf \
+			"${D}"/usr/share/snmp/snmp_perl_trapd.pl \
+			|| die
+	fi
+
+	dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO
+	newdoc EXAMPLE.conf.def EXAMPLE.conf
+
+	if use doc; then
+		docinto html
+		dodoc -r docs/html/*
+	fi
+
+	keepdir /var/lib/net-snmp
+
+	newinitd "${FILESDIR}"/snmpd.init.2 snmpd
+	newconfd "${FILESDIR}"/snmpd.conf snmpd
+
+	newinitd "${FILESDIR}"/snmptrapd.init.2 snmptrapd
+	newconfd "${FILESDIR}"/snmptrapd.conf snmptrapd
+
+	systemd_dounit "${FILESDIR}"/snmpd.service
+	systemd_dounit "${FILESDIR}"/snmptrapd.service
+
+	insinto /etc/snmp
+	newins "${S}"/EXAMPLE.conf snmpd.conf.example
+
+	# Remove everything not required for an agent.
+	# Keep only the snmpd, snmptrapd, MIBs, headers and libraries.
+	if use minimal; then
+		rm -rf \
+			"${D}"/**/*.pl \
+			"${D}"/usr/bin/{encode_keychange,snmp{get,getnext,set,usm,walk,bulkwalk,table,trap,bulkget,translate,status,delta,test,df,vacm,netstat,inform,check,conf},fixproc,traptoemail} \
+			"${D}"/usr/share/snmp/*.conf \
+			"${D}"/usr/share/snmp/snmpconf-data \
+			|| die
+	fi
+
+	prune_libtool_files
+}
-- 
cgit v1.2.3-65-gdbad