From 0c858706cfe15be83cbf86ff847c8f2ed2565c89 Mon Sep 17 00:00:00 2001
From: Göktürk Yüksek <gokturk@gentoo.org>
Date: Fri, 6 Jul 2018 15:24:15 -0400
Subject: app-crypt/jitterentropy: initial commit with version 2.1.1

The Jitter RNG provides a noise source using the CPU execution timing
jitter.

It is an optional dependency for >=rng-tools-6.3.

Package-Manager: Portage-2.3.41, Repoman-2.3.9
---
 app-crypt/jitterentropy/Manifest                   |  1 +
 .../files/jitterentropy-2.1.1-destdir-fix.patch    | 37 +++++++++++++++++++
 app-crypt/jitterentropy/jitterentropy-2.1.1.ebuild | 41 ++++++++++++++++++++++
 app-crypt/jitterentropy/metadata.xml               | 18 ++++++++++
 4 files changed, 97 insertions(+)
 create mode 100644 app-crypt/jitterentropy/Manifest
 create mode 100644 app-crypt/jitterentropy/files/jitterentropy-2.1.1-destdir-fix.patch
 create mode 100644 app-crypt/jitterentropy/jitterentropy-2.1.1.ebuild
 create mode 100644 app-crypt/jitterentropy/metadata.xml

(limited to 'app-crypt/jitterentropy')

diff --git a/app-crypt/jitterentropy/Manifest b/app-crypt/jitterentropy/Manifest
new file mode 100644
index 000000000000..32b6d5221e59
--- /dev/null
+++ b/app-crypt/jitterentropy/Manifest
@@ -0,0 +1 @@
+DIST jitterentropy-2.1.1.tar.gz 23804 BLAKE2B e208c87b414939485c16c6e94460020164e77089d5ac69f8627f8f1dfb38f211ff985c7fa5d32f647f1b06f065f86dc9070aea9b481e8251ecdecbfb4724ce08 SHA512 fb1b76278e03f425be06c8b66532e3997a07f91645393317f42681b1113bd31dfdf348bd18c92d0dfc153c85b75f8f968fe070e988f1a02e4ef4e09435b6cef8
diff --git a/app-crypt/jitterentropy/files/jitterentropy-2.1.1-destdir-fix.patch b/app-crypt/jitterentropy/files/jitterentropy-2.1.1-destdir-fix.patch
new file mode 100644
index 000000000000..cdcc2a57756f
--- /dev/null
+++ b/app-crypt/jitterentropy/files/jitterentropy-2.1.1-destdir-fix.patch
@@ -0,0 +1,37 @@
+From 4b5dc596547e0833e2cccf65efa46ecbe7d0b99c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?G=C3=B6kt=C3=BCrk=20Y=C3=BCksek?= <gokturk@gentoo.org>
+Date: Fri, 6 Jul 2018 14:41:52 -0400
+Subject: [PATCH] Makefile: add support for $(DESTDIR) in install target
+
+Allow install target to install into an arbitrary root instead of '/'
+by prefixing $(PREFIX) with $(DESTDIR).
+---
+ Makefile | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c38b800..2c778f2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -44,11 +44,13 @@ scan:	$(OBJS)
+ 	scan-build --use-analyzer=/usr/bin/clang $(CC) -shared -Wl,-soname,lib$(NAME).so.$(LIBMAJOR) -o lib$(NAME).so.$(LIBVERSION) $(OBJS) $(LDFLAGS)
+ 
+ install:
+-	install -m 644 doc/$(NAME).3 $(PREFIX)/share/man/man3/
+-	gzip -9 $(PREFIX)/share/man/man3/$(NAME).3
+-	install -m 0755 -s lib$(NAME).so.$(LIBVERSION) $(PREFIX)/$(LIBDIR)/
+-	$(RM) $(PREFIX)/$(LIBDIR)/lib$(NAME).so.$(LIBMAJOR)
+-	ln -s lib$(NAME).so.$(LIBVERSION) $(PREFIX)/$(LIBDIR)/lib$(NAME).so.$(LIBMAJOR)
++	install -d -m 0755 $(DESTDIR)$(PREFIX)/share/man/man3
++	install -m 644 doc/$(NAME).3 $(DESTDIR)$(PREFIX)/share/man/man3/
++	gzip -9 $(DESTDIR)$(PREFIX)/share/man/man3/$(NAME).3
++	install -d -m 0755 $(DESTDIR)$(PREFIX)/$(LIBDIR)
++	install -m 0755 -s lib$(NAME).so.$(LIBVERSION) $(DESTDIR)$(PREFIX)/$(LIBDIR)/
++	$(RM) $(DESTDIR)$(PREFIX)/$(LIBDIR)/lib$(NAME).so.$(LIBMAJOR)
++	ln -s lib$(NAME).so.$(LIBVERSION) $(DESTDIR)$(PREFIX)/$(LIBDIR)/lib$(NAME).so.$(LIBMAJOR)
+ 
+ clean:
+ 	@- $(RM) $(NAME)
+-- 
+2.17.0
+
diff --git a/app-crypt/jitterentropy/jitterentropy-2.1.1.ebuild b/app-crypt/jitterentropy/jitterentropy-2.1.1.ebuild
new file mode 100644
index 000000000000..70e643f40806
--- /dev/null
+++ b/app-crypt/jitterentropy/jitterentropy-2.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hardware RNG based on CPU timing jitter"
+HOMEPAGE="https://github.com/smuellerDD/jitterentropy-library"
+SRC_URI="https://github.com/gktrk/jitterentropy-library/archive/v2.1.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+	"${FILESDIR}"/${PN}-2.1.1-destdir-fix.patch
+)
+
+S="${WORKDIR}/${PN}-library-${PV}"
+
+src_prepare() {
+	default
+
+	# Disable man page compression on install
+	sed -e '/\tgzip.*man/ d' -i Makefile || die
+	# Let the package manager handle stripping
+	sed -e '/\tinstall.*-s / s/-s //g' -i Makefile || die
+}
+
+src_compile() {
+	emake CC="$(tc-getCC)"
+}
+
+src_install() {
+	emake PREFIX="${EPREFIX}/usr" \
+		  LIBDIR="$(get_libdir)" \
+		  DESTDIR="${D}" install
+	dosym lib${PN}.so.${PV} "/usr/$(get_libdir)"/lib${PN}.so
+	doheader ${PN}.h ${PN}-base-user.h
+}
diff --git a/app-crypt/jitterentropy/metadata.xml b/app-crypt/jitterentropy/metadata.xml
new file mode 100644
index 000000000000..4cf1945b408e
--- /dev/null
+++ b/app-crypt/jitterentropy/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+	<email>gokturk@gentoo.org</email>
+	<name>Göktürk Yüksek</name>
+</maintainer>
+<longdescription>
+	The Jitter RNG provides a noise source using the CPU execution
+	timing jitter. It does not depend on any system resource other
+	than a high-resolution time stamp. It is a small-scale, yet
+	fast entropy source that is viable in almost all environments
+	and on a lot of CPU architectures.
+</longdescription>
+<upstream>
+	<remote-id type="github">smuellerDD/jitterentropy-library</remote-id>
+</upstream>
+</pkgmetadata>
-- 
cgit v1.2.3-65-gdbad