From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 app-emacs/bbdb/bbdb-3.1.2.ebuild | 60 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)
 create mode 100644 app-emacs/bbdb/bbdb-3.1.2.ebuild

(limited to 'app-emacs/bbdb/bbdb-3.1.2.ebuild')

diff --git a/app-emacs/bbdb/bbdb-3.1.2.ebuild b/app-emacs/bbdb/bbdb-3.1.2.ebuild
new file mode 100644
index 000000000000..8c45e10c2955
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-3.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp autotools
+
+DESCRIPTION="The Insidious Big Brother Database"
+HOMEPAGE="http://savannah.nongnu.org/projects/bbdb/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ GPL-1+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="tex vm"
+
+DEPEND="tex? ( virtual/tex-base )
+	vm? ( app-emacs/vm )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+	epatch "${FILESDIR}"/${P}-no-init.patch
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		--with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+		"$(use_with vm vm-dir "${EPREFIX}${SITELISP}/vm")"
+}
+
+src_compile() {
+	emake -C lisp
+}
+
+src_install() {
+	emake -C lisp DESTDIR="${D}" install
+	elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+	doinfo doc/*.info*
+	dodoc AUTHORS ChangeLog NEWS README TODO
+
+	if use tex; then
+		insinto "${TEXMF}"/tex/plain/${PN}
+		doins tex/*.tex
+	fi
+}
+
+pkg_postinst() {
+	elisp-site-regen
+	use tex && texconfig rehash
+}
+
+pkg_postrm() {
+	elisp-site-regen
+	use tex && texconfig rehash
+}
-- 
cgit v1.2.3-65-gdbad