From 0464e778f553069f2389eb4976bf6adb29cef93e Mon Sep 17 00:00:00 2001
From: Brian Dolbec <dolsen@gentoo.org>
Date: Sun, 22 May 2016 13:21:17 -0700
Subject: app-portage/repoman: Add 9999 live ebuild

Package-Manager: portage-2.3.0_rc1
---
 app-portage/repoman/repoman-9999.ebuild | 108 ++++++++++++++++++++++++++++++++
 1 file changed, 108 insertions(+)
 create mode 100644 app-portage/repoman/repoman-9999.ebuild

(limited to 'app-portage')

diff --git a/app-portage/repoman/repoman-9999.ebuild b/app-portage/repoman/repoman-9999.ebuild
new file mode 100644
index 000000000000..dc0b12c09daa
--- /dev/null
+++ b/app-portage/repoman/repoman-9999.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(
+	pypy
+	python3_3 python3_4 python3_5
+	python2_7
+)
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1 git-r3 multilib
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	dev-lang/python-exec:2
+	=sys-apps/portage-9999
+	"
+
+RDEPEND="
+	dev-lang/python-exec:2
+	=sys-apps/portage-9999
+	"
+
+SRC_ARCHIVES="https://dev.gentoo.org/~dolsen/releases/repoman"
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/portage.git
+	https://github.com/gentoo/portage.git"
+
+prefix_src_archives() {
+	local x y
+	for x in ${@}; do
+		for y in ${SRC_ARCHIVES}; do
+			echo ${y}/${x}
+		done
+	done
+}
+
+TARBALL_PV=${PV}
+SRC_URI=""
+
+S="${WORKDIR}/${P}/repoman"
+
+python_prepare_all() {
+	distutils-r1_python_prepare_all
+
+	if [[ -n ${EPREFIX} ]] ; then
+		einfo "Setting portage.const.EPREFIX ..."
+		sed -e "s|^\(SANDBOX_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/sandbox\"\)|\\1${EPREFIX}\\2|" \
+			-e "s|^\(FAKEROOT_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/fakeroot\"\)|\\1${EPREFIX}\\2|" \
+			-e "s|^\(BASH_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/bash\"\)|\\1${EPREFIX}\\2|" \
+			-e "s|^\(MOVE_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/mv\"\)|\\1${EPREFIX}\\2|" \
+			-e "s|^\(PRELINK_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/sbin/prelink\"\)|\\1${EPREFIX}\\2|" \
+			-e "s|^\(EPREFIX[[:space:]]*=[[:space:]]*\"\).*|\\1${EPREFIX}\"|" \
+			-i pym/portage/const.py || \
+			die "Failed to patch portage.const.EPREFIX"
+
+		einfo "Prefixing shebangs ..."
+		while read -r -d $'\0' ; do
+			local shebang=$(head -n1 "$REPLY")
+			if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
+				sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \
+					die "sed failed"
+			fi
+		done < <(find . -type f -print0)
+	fi
+}
+
+python_test() {
+	esetup.py test
+}
+
+python_install() {
+	# Install sbin scripts to bindir for python-exec linking
+	# they will be relocated in pkg_preinst()
+	distutils-r1_python_install \
+		--system-prefix="${EPREFIX}/usr" \
+		--bindir="$(python_get_scriptdir)" \
+		--docdir="${EPREFIX}/usr/share/doc/${PF}" \
+		--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+		--sbindir="$(python_get_scriptdir)" \
+		--sysconfdir="${EPREFIX}/etc" \
+		"${@}"
+}
+
+python_install_all() {
+	distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+	einfo ""
+	einfo "This release of repoman is from the new portage/repoman split"
+	einfo "release code base."
+	einfo "This new repoman code base is still being developed.  So its API's"
+	einfo "are not to be considered stable and are subject to change."
+	einfo "The code released has been tested and considered ready for use."
+	einfo "This however does not guarantee it to be completely bug free."
+	einfo "Please report any bugs you may encounter."
+	einfo ""
+}
-- 
cgit v1.2.3-65-gdbad