From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 app-text/wdiff/Manifest           |  1 +
 app-text/wdiff/metadata.xml       |  8 ++++++++
 app-text/wdiff/wdiff-1.2.2.ebuild | 34 ++++++++++++++++++++++++++++++++++
 3 files changed, 43 insertions(+)
 create mode 100644 app-text/wdiff/Manifest
 create mode 100644 app-text/wdiff/metadata.xml
 create mode 100644 app-text/wdiff/wdiff-1.2.2.ebuild

(limited to 'app-text/wdiff')

diff --git a/app-text/wdiff/Manifest b/app-text/wdiff/Manifest
new file mode 100644
index 000000000000..5dc16e679930
--- /dev/null
+++ b/app-text/wdiff/Manifest
@@ -0,0 +1 @@
+DIST wdiff-1.2.2.tar.gz 1478567 SHA256 34ff698c870c87e6e47a838eeaaae729fa73349139fc8db12211d2a22b78af6b SHA512 9272c225f4f61612197fe151cf8c913107169ac9fcd6c9f8472a0f56d9124d78a060944cea1b51489ca34311220f23638d043d43c733a3252cdbb7cceb1085ed WHIRLPOOL 39bff8de5fcb0b98ba18a636d57ccde0e422c2ecddac5a4623fef03cad0a92c68ccb25272a9b0fefdb6b109c5354ce201be317f293e07f18592f3214049cafe7
diff --git a/app-text/wdiff/metadata.xml b/app-text/wdiff/metadata.xml
new file mode 100644
index 000000000000..4fb185fbe049
--- /dev/null
+++ b/app-text/wdiff/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>shell-tools</herd>
+  <use>
+    <flag name="experimental">Build experimental utilities (mdiff, unify, wdiff2)</flag>
+  </use>
+</pkgmetadata>
diff --git a/app-text/wdiff/wdiff-1.2.2.ebuild b/app-text/wdiff/wdiff-1.2.2.ebuild
new file mode 100644
index 000000000000..ed6f19f040f2
--- /dev/null
+++ b/app-text/wdiff/wdiff-1.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="http://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="experimental test"
+
+RDEPEND="
+	sys-apps/diffutils
+	sys-apps/less
+	sys-libs/ncurses"
+DEPEND="${RDEPEND}
+	test? ( app-misc/screen )"
+
+src_configure() {
+	econf \
+		$(use_enable experimental)
+}
+
+src_test() {
+	# The test suite hangs in the '3: use pager' test
+	# when an incompatible screenrc is found
+	touch tests/screenrc || die
+	export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
+	default
+}
-- 
cgit v1.2.3-65-gdbad