From 3cb8d20c8f4e3d211e1acfc05cb7fc3ea4dc3a2d Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Thu, 4 Mar 2021 04:56:18 +0000
Subject: dev-libs/hiredis: remove 0.14.1

Signed-off-by: Sam James <sam@gentoo.org>
---
 dev-libs/hiredis/Manifest              |  1 -
 dev-libs/hiredis/hiredis-0.14.1.ebuild | 81 ----------------------------------
 2 files changed, 82 deletions(-)
 delete mode 100644 dev-libs/hiredis/hiredis-0.14.1.ebuild

(limited to 'dev-libs/hiredis')

diff --git a/dev-libs/hiredis/Manifest b/dev-libs/hiredis/Manifest
index bee3dbedda04..8da38f2fc132 100644
--- a/dev-libs/hiredis/Manifest
+++ b/dev-libs/hiredis/Manifest
@@ -1,2 +1 @@
-DIST hiredis-0.14.1.tar.gz 64372 BLAKE2B 9846b05e21bfadb876e26ab45bf5c29a3283b602ef725dfbd877815be690bb5579551f0c452e1d8abf9ae985f6b71408a3b86b343ca5d6dce58dd4897640996a SHA512 a7310f2d65075df0c17636a0220e16487759471a3442b1de2595ab747565f6b6262e37131613b13e396b31050bcbe5529c35d420cd43fd7d500d9d563d469c4f
 DIST hiredis-1.0.0.tar.gz 97507 BLAKE2B 247852d53be96e36dbdd7d4d8cfbda4406aa66281f26c28c3f80ab4593679122fd59430b2d5f04d20126b4459fc75af0a1fd67f1ee1db691d8db575debad2b61 SHA512 eb56201121eecdbfc8d42e8c2c141ae77bea248eeb36687ac6835c9b2404f5475beb351c4d8539d552db4d88e933bb2bd5b73f165e62b130bb11aeff39928e69
diff --git a/dev-libs/hiredis/hiredis-0.14.1.ebuild b/dev-libs/hiredis/hiredis-0.14.1.ebuild
deleted file mode 100644
index d3827b66b401..000000000000
--- a/dev-libs/hiredis/hiredis-0.14.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Minimalistic C client library for the Redis database"
-HOMEPAGE="https://github.com/redis/hiredis"
-SRC_URI="https://github.com/redis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/0.14"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86 ~x64-solaris"
-IUSE="examples static-libs test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-db/redis )"
-
-src_prepare() {
-	local PATCHES=(
-		"${FILESDIR}"/${PN}-0.13.3-disable-network-tests.patch
-		"${FILESDIR}"/${PN}-0.14.1-honor-AR.patch
-	)
-	default
-
-	# use GNU ld syntax on Solaris
-	sed -i -e '/DYLIB_MAKE_CMD=.* -G/d' Makefile || die
-}
-
-_build() {
-	emake \
-		AR="$(tc-getAR)" \
-		CC="$(tc-getCC)" \
-		PREFIX="${EPREFIX}/usr" \
-		LIBRARY_PATH="$(get_libdir)" \
-		DEBUG_FLAGS= \
-		OPTIMIZATION= \
-		"$@"
-}
-
-src_compile() {
-	# The static lib re-uses the same objects as the shared lib, so
-	# overhead is low w/creating it all the time.  It's also needed
-	# by the tests.
-	_build dynamic static hiredis.pc
-}
-
-src_test() {
-	local REDIS_PID="${T}"/hiredis.pid
-	local REDIS_SOCK="${T}"/hiredis.sock
-	local REDIS_PORT=56379
-	local REDIS_TEST_CONFIG="daemonize yes
-		pidfile ${REDIS_PID}
-		port ${REDIS_PORT}
-		bind 127.0.0.1
-		unixsocket //${REDIS_SOCK}"
-
-	_build hiredis-test
-
-	/usr/sbin/redis-server - <<< "${REDIS_TEST_CONFIG}" || die
-	./hiredis-test -h 127.0.0.1 -p ${REDIS_PID} -s ${REDIS_SOCK}
-	local ret=$?
-
-	kill "$(<"${REDIS_PID}")" || die
-	[ ${ret} != "0" ] && die "tests failed"
-}
-
-src_install() {
-	_build PREFIX="${ED}/usr" install
-	if ! use static-libs; then
-		find "${ED}" -name '*.a' -delete || die
-	fi
-
-	insinto /usr/$(get_libdir)/pkgconfig
-	doins ${PN}.pc
-
-	local DOCS=( CHANGELOG.md README.md )
-	use examples && DOCS+=( examples )
-	einstalldocs
-}
-- 
cgit v1.2.3-65-gdbad